Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint 2010 environment where I am unable to open .mht files in my browser. Every time reference the .mht file using a page viewer web part or a content editor web part (with iframe) I am shown a prompt to save the .mht file to disk.

I have already set the Browser File Handling to Permissive for the web application.

The Browser I am using is Internet Explorer 9. Might this be causing the problem? In a virtual machine using Internet Explorer 8 I am not confronted with this prompt.

How can I make sure .mht files are opened in the browser window itself instead of receiving a prompt to save to disk.

share|improve this question
    
We have a user that is having this problem as well in IE9. Did you ever find a resolution? –  Carolyn Apr 24 '13 at 13:20
    
Hello Carolyn, I have not found a solution for this. –  TempaC Apr 25 '13 at 11:16

2 Answers 2

up vote 1 down vote accepted

You're not alone ! This is related to Internet Explorer 9 (and 10) handling of MHT files. While you can open them when they are saved locally, you can't run them anymore like other content types with the default settings.

Ensure that .mht are associated with IE, then check that the site is in the trusted zone (or intranet) and security settings are set to low. You can also try to run the site in compatibility mode.

Hope it helps.

share|improve this answer
    
Thank you for your comment. I was afraid of this being the case. The MHT extension is associated with IE and the site is in the trusted zone and using compatibility mode. The weird thing is that I am also unable to open the .mht files in Internet Explorer 8. If anyone has any more suggestions? –  TempaC Mar 19 '13 at 15:12
1  
Did you try with another .mht files ? Ensure that you can save a somehow simple one like the google homepage and open it straight away in IE8 and IE9 then upload it in SP and try to open it without saving it. This might also be an issue with specific mht file(s) –  Francois Verbeeck Mar 19 '13 at 15:25
    
I created a simple MHT file with only text to test like you suggested. When uploading the MHT file to a document library and opening it, I only receive the prompt to save the document. –  TempaC Mar 19 '13 at 15:35
1  
and it was ok when you opened it locally ? Could you put it at the root of a site in IIS and call it from there to exclude SharePoint or make it the culprit in this behavior ? –  Francois Verbeeck Mar 19 '13 at 15:38
    
Alright, so I created a new folder in IIS and added the test MHT file containing only text. When I browse to the location on my IIS server using Internet Explorer 9 it opens without a problem. Adding a more complex MHT file also opens without a prompt. When I browse from a client machine to the location, I am greeted by a save as prompt. –  TempaC Mar 19 '13 at 15:49

enter image description here

Once you set the Browser File Handling to Permissive for the web application. After that Go to SharePoint Document Library --> Library Settings --> Advanced Settings change setting. (As like Above image)

share|improve this answer
    
Thank you for your useful comment. I set the behavior for the Site Assets folder to "Open in Browser". Alas I am still unable to open the .mht file directly in my browser. I still need to save it to disk first. –  TempaC Mar 19 '13 at 13:09
    
Could my browser version be the cause of this prompt? –  TempaC Mar 19 '13 at 14:39
1  
I checked IE9 Working fine. so you kindly check it is working in IE Browser. –  Nagaraju Pattem Mar 20 '13 at 4:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.