Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

How can I disable Anonymous Access to my sharepoint sites? I am without access to the Site Collecition Administration page, and can not seem to find this solution anywhere online.

When I go to the Permissions:website there is no button in the server ribbon for Anonymous Access.

In Sharepoint Designer, when I click the Anonymous Access button, it opens a browser with the sharepoint.website/_layouts/setanon.aspx and returns a 404 error.

Publishing is not enabled.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

This is a top-level site with anonymous access enabled:

enter image description here

All of my sub-sites inherit from this so when I go to them the "Anonymous Access" button in the image above is just gone. You might want to try breaking the inheritance if you're not working with the top-level site in your site collection. If you can't do any of this you probably don't have permission to make the changes and you should contact the person in your organization who does, or the support group for this site's hosting.

Here's a subsite for the site above, notice the button for breaking inheritance:

enter image description here

If you are ALREADY at your top-level site and you do not see what I posted above, then you probably do not have anonymous access enabled. This is a top-level site WITHOUT anonymous access enabled:

enter image description here

Notice how there's no "Anonymous Access" button.

share|improve this answer
    
Thank you for your detailed response, Matt. As per your images, it is the case that I see at my top-level site, that I am without Anonymous Access enabeled. Yet I do see the greyed out Anonymous Users with Entire Website Permission Levels. img this image is at the top level site –  Scott Mar 18 '13 at 17:11
    
Hmm. Well that's different. I guess then I would check to make sure you have permission to those settings. Are you a site collection admin or owner for that site collection? I switched off anonymous access at the web application level in central admin and not only did the button go away on my site but the anonymous users went away, too. –  Matt Mar 18 '13 at 18:10
    
After speaking with MS Support, we found that the problem that we were having was as a result of the Site Collection having been set up as a website at the outset. The website would obviously be visible by anonymous users. –  Scott Mar 18 '13 at 19:16
add comment

By default your site should be set to Anonymous access disabled...to enable follow this link for a run through. If yours is already enabled you can work it out from info below.

Enable Anonymous Access in SharePoint 2010

To access central admin you need to goto https://portal.microsoftonline.com and enter your credentials.

share|improve this answer
    
Thank you Stephen for the quick response, I appreciate the help. In my research, I navigated to the page that you have linked me to. The first listed step on that page is to go to Central Administration- which I can't access. It is a mystery as to why Anonymous Access is enabled, but it is obvious that it is enabled because at the Permissions:website page, "Anonymous Access" is a greyed out group member. –  Scott Mar 18 '13 at 15:47
    
Is this SP Online? You will need Central admin access to do this. –  Stephen Mar 18 '13 at 15:48
    
Yes the site is online. Researching now how to access Central Admin. Thank you for your help, sir. –  Scott Mar 18 '13 at 15:51
    
Updated my answer. –  Stephen Mar 18 '13 at 15:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.