Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a script that adds a set of items to a list one by one in a loop. The items are added fine and the "Title" column contains the correct title for each row. However, both of the LinkTitle and LinkTitleNoMenu columns are not filled in correctly. From what I understand those two columns should be "computed" from the Title column. For me that computation does not seem to be working. I have the following (simplified) code:

    ListItemCreationInformation listICI = new ListItemCreationInformation();
    listICI.FolderUrl = "http://myurl";
    var item = updateList.AddItem(listICI);
    item["Title"] = "MyTitle";
    // Add other columns in here...
    item.Update();
    cc.ExecuteQuery();

When I execute the above code I get:

  • Title = "MyTitle"
  • LinkTitle = 2_.000
  • LinkTitleNoMenu = 2_.000

I am looking for this:

  • Title = "MyTitle"
  • LinkTitle = "MyTitle"
  • LinkTitleNoMenu = "MyTitle"

How do I force the other two columns to take the correct value from the Title column?

Thank you in advance, Stefan

share|improve this question
    
Have you tried assigning LinkTitle and LinkTitleNoMenu explicitly the same way as you assign Title? –  Eugene Mar 15 '13 at 22:27
    
Thank you for the reply. Yes I have tried to assign each one directly but I get the run-time error: "The field you are trying to update may be read only." –  Stefan Mar 18 '13 at 13:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.