Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am using ITACs change password web part to allow users to change their own passwords.

It is showing the logged in user as "IUSR"

In a web application in classic authentication mode it works perfectly.

In a web app using CBA -> FBA, it is showing IUSR as current user.

Anonymous access is disabled in the web app.

In web.config

identity impersonate="true"

add key="aspnet:AllowAnonymousImpersonation" value="true"

I have tried setting both to false also. And when I do, the user name changes to the farm account.

I need to make the logged in users name show up.

Server 2008R2, Sharepoint 2010 SP1

share|improve this question

2 Answers 2

You are using FBA to provide identity. Your FBA provider needs to manage passwords. I don't know what ITAC is, but I am assuming that it manages Active Directory. No amount of fiddling with web.config (which is a very bad idea anyway) will help.

share|improve this answer
    
The web part reads the current user, then passes the password reset through the LDAP connection. The problem is, the current user is being seen as IUSR with impersonation enabled, or farm account with it disabled. –  Matt Bear Mar 14 '13 at 22:15
    
I am using FBA with an LDAP connection to AD for users management. –  Matt Bear Mar 14 '13 at 22:16
    
The FBA identity applies only to the HTTP request and SharePoint. Not the thread or process identity. Again, the FBA provider needs to manage the credentials. You can learn more about identities here: schaeflein.net/Pages/… –  Paul Schaeflein Mar 14 '13 at 22:25
up vote 0 down vote accepted

It's not a direct answer for ITACs Change Password web part not picking up the user name, but http://sharepoint2010fba.codeplex.com/ is an FBA management pack, which actually works much better then ITACS and solved my problem. So no answer, but a work around.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.