SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem when I try to start a Workflow 2013 in SharePoint Server 2013. I believe the error is related with permissions, but I cannot be sure.

Here is the error message in the log:

RequestorId: ef9edb7c-cc3d-5e10-3681-eada907596a4. 
Details: System.ApplicationException: HTTP 401 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPRequestGuid":["ef9edb7c-cc3d-5e10-3681-eada907596a4"],"request-id":["ef9edb7c-cc3d-5e10-3681-eada907596a4"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":[""],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Thu, 31 Jan 2013 16:36:44 GMT"],"Server":["Microsoft-IIS\/8.0"],"WWW-Authenticate":["NTLM"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} 
The HTTP response content could not be read. 
'Error while copying content to a stream.'. at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem

The question is: What permissions do I need to configure in SharePoint for the WF publisher and the WF manager service account?

I’ve set a WF Manager service account named “wfservice” (this account is a local admin and has the sysadmin permissions in SQL Server), and I published the workflow and tested it using the account “wfuser”. Both accounts have full control permissions in the web app and are site owners, for testing WF 2013 purposes.

I’ve already done the DNS flush, as mentioned in Andrew Connell’s article, and I’m still getting an Unauthorized exception in the Item Workflow Status.

Anyone knows what’s going on? Which permissions do I need to configure?

share|improve this question

migrated from Mar 13 '13 at 14:35

This question came from our site for professional and enthusiast programmers.

I was getting the same error, found the solution

hope this solution works for you too.

share|improve this answer

The error text that pasted indicates that you're getting access denied on workflow calling back to SharePoint.

Workflow uses signed security tokens to authenticate. The SharePoint Web Application must be claims enabled and not use Forms Based Authentication (which is a requirement of SharePoint OAuth).

Because the response header only includes WWW-Authenticate: NTLM it would seem that SharePoint is not configured for server-to-server authentication (

share|improve this answer
I tried to run the following script and doesn't work: New-SPTrustedSecurityTokenIssuer -Name "WFManagerFarm1" -MetadataEndPoint "http://<hostname>/sites/test/_layouts/15/metadata/json/1"; I also have my web application with claims-based enabled. Is my script correct? – António Vargas Feb 15 '13 at 17:51

just activate the workflow can use app permission site feature. It should be Work

share|improve this answer
ya its works for me – naveen Jul 1 at 7:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.