Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have installed and configured sSharePoint 2013 workflow manager according to the instructions on msdn. When i create a simple workflow in SharePOint designer, just one task, the task gets canceled and this error message appears:

RequestorId: 07d0dc78-24ac-7c71-78a3-fcefb293ccf8. Details: System.ArgumentException: ContentTypeId at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Does anybody know what the problem is?

Thanks //Joakim

share|improve this question

migrated from stackoverflow.com Mar 13 '13 at 14:35

This question came from our site for professional and enthusiast programmers.

    
Me too, I have much more items ,only one item error –  user21969 Jan 15 at 6:41

2 Answers 2

This issue is caused by the fact that content type that is used for workflow task was not added to workflow task list.

To fix it:

  1. Check the name of task content type that is used in workflow.
  2. Check which list is assigned as "Task list" for workflow.
  3. Go to workflow task list > list settings > content types section and verity you task content type is present.

If your task content type is not present in the list - just add it :)

First:

http://i.stack.imgur.com/DYkxG.png

Second:

http://i.stack.imgur.com/EjGmx.png

share|improve this answer
    
Link to the task setting screen: link –  Stanislav Feb 24 '13 at 19:43
    
I am getting the same above error, however list and content type are perfectly associated, any other thing need to check? –  Anuja Mar 14 '13 at 7:59

We had the same issue. It is a bug in the latest SharePoint update. MS says it will be fixed in June in an update. I cannot believe they have released an update with such a big bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.