SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to sharepoint, so maybe I am missing something obvious, but I can't delete document library off my sharepoint site for some reason.

I set myself up as the admin of this sharepoint site, and I have "Full Control" on my account, yet when I try to edit a page for a document library and go to delete it...the button is greyed out and I get a tooltip that says "This control is currently disabled" and "You might not have the right permission levels to perform this operation"

With full control being checked, shouldn't I be able to delete the lib?

Am I missing something?

I am running SP2010

EDIT 2 I figured it out. Once I realized I was trying to delete a library (originally I was trying to delete the library page, thinking that was the same) I googled and found this:

I am still not sure why deleting libraries is so awkward....but it works and I understand what I was doing wrong now. Hopefully if any other SP noobs out there run into this they will find it helpful.

share|improve this question

migrated from Mar 12 '13 at 16:27

This question came from our site for professional and enthusiast programmers.

Hi, If its on the page then probably you are trying to delete the List View Web Part of the document library because deleting a document library is about to go in Library Settings -> Delete this library. Just check if the page where your list view web part lies is inheriting permission from its parent web, if it is not inheriting then you should add yourself to the page permission. Hope this helps. – Zakir HC Mar 13 '13 at 13:30

Default Document library cannot be deleted directly, it has a property that prevent users to do it. You can remove the property with powershell using this guide

$web = Get-SPWeb("http://YourSite")

$list = $web.Lists["Documents"]

$list.AllowDeletion = $true


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.