Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a content query web part to aggregate documents in document libraries within the site (not site collection). I am receiving this message:

Your query returned a greater number of results than the web application's query throttling limit. Please adjust the configuration of this Web Part or increase the throttling limit.

My filters are set up to return a small number of documents (definitely less than the 5K limit). For example, I have set up a filter to only return documents I've created [Today], which right now is only 2. I am still getting that message. There are 5 document libraries in the site. One of them does have over 8K items. Is this reason? If yes, why - if my filter should only return 2? How can I get this working?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Generally the error occurs when the list has reached the threshold limit. Even though your query might be saying "where createdDate=Today", SharePoint has to parse through all the items in the list & when it finds out that the limit of 5K is reached, it throws error.

Increase the limit in Central admin for that web application

OR

User custom webpart + run with Elevated() to overcome the threshold limit to some extent.(20K)

share|improve this answer
    
Are these 2 the only options? It is O365, so I cannot run in Elevated() privileges (I think). –  obautista Mar 11 '13 at 17:14

You can try:

Goto the library settings and look under "metadata navigation settings".

look at the image below as it should look like that. If you have somthing in content type then remove it and exit.

Now try and search again :)

content type

http://office.microsoft.com/en-gb/sharepoint-server-help/configure-metadata-navigation-for-a-list-or-library-HA101820113.aspx

I think i might have somthing todo with it as throttling by default is set to 5000 and you have 8k. I think when it searches that it has a pool of all documents in document library and lists. You can do the method above to resolve the issue and if not you can try to change the throttling from 5k to 8k just to see if it works. But i belive my first solution should solve your issue :) . for bigger throttling limmit refer to this:

http://ybbest.wordpress.com/2013/01/27/truly-understand-the-threshold-for-document-set-in-document-library-in-sharepoint/

share|improve this answer
    
In the library that contains 8K + documents, Metadata Navigation Settings/Configure Navigation Hierarchies shows "Folders" as the only "Selected Hierarchy Fields". –  obautista Mar 9 '13 at 16:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.