Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've seen a couple of demos where people add a YouTube link to their newsfeed, and a Facebook style thumbnail with a video preview is displayed. The same thing happens on my Office 365 account.

For some reason, my on-premises install of SP2013 is not doing that. It is just displaying the link as text. Does this not work on premises at all, or am I missing a config somewhere?

share|improve this question
    
Can you check if thumbnails are appearing in search results when you perform a search –  Muhammad Raja Mar 9 '13 at 10:03
    
I get the preview of the conversation but I don't get any video thumbnail either. –  Jorge Carvalho Mar 11 '13 at 1:26
    
Muhammad, Even for videos hosted in SharePoint, I get the thumbnail on the newsfeed, but not on the search preview –  Jorge Carvalho Mar 11 '13 at 2:20
    
On my on-prem 2013 farm it simply shows up as a hyperlink - no thumbnail. –  user14690 Oct 11 '13 at 19:23
    
Having the same problem. It worked on O365, but isn't working on prem? –  user24414 Mar 14 at 17:45

5 Answers 5

I think your talking about embedding videos?

If you type in a link to a youtube or video you have stored on your SharePoint site you get a very cool preview automatically generated for you:

embedding video

http://www.sharepointanalysthq.com/2012/07/social-in-sharepoint-2013-newsfeed-posting-and-replying/

follow these steps:

You can embed videos from YouTube and similar services in a newsfeed post. The process for doing this is similar to the one described above for including links to Web pages. You paste a link to the video into the post and optionally replace it with display text. A video thumbnail appears in the post ready for you and others to run in a video player.

1.Go to the video in its service and copy its URL to the clipboard.

2.In your newsfeed, paste the video URL into a new post, and press Enter. You see a thumbnail for the video, and an option to format the video URL with display text.

enter image description here

3.If you want, type in display text for the video URL, and click the check mark.

enter image description here

4.Click Post to complete the newsfeed entry.

enter image description here

http://office.microsoft.com/en-gb/sharepoint-help/add-features-to-a-newsfeed-post-HA102785751.aspx#_Toc328036827

share|improve this answer
    
Yes Ali, I'm talking about embedding videos. Like I said, it works on my office 365 account, but not on premises. Can you confirm that it works in your on-premises farm, and if you had to do any specific configuration? –  Jorge Carvalho Mar 11 '13 at 0:39

Do you have a proxy in your company? The app-pool-account needs internet access to generate the preview, check the proxy settings for that user.

share|improve this answer

I had the same issue, along with error 8311 in the events related to certificate validation issue with *.google.com

The following worked for me:

  • Go to gmail.com, view the certificate (the lock in IE) and download the root certificate "Geo Trust Global CA"

  • Import the certificate in the computer certificate store under "Trusted Root Certification Authorities"

Now all the links from youtube display the thumbnail / preview

share|improve this answer

If you are using a proxy server, this error occurs, here is an detailed explanation http://sharepointjournal.com/2014/10/29/sharepoint-2013-newsfeed-not-showing-video-preview-thumbnails/

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

    
Links tend to break over time rendering link-only answers useless. Please summarize the steps required to resolve the problem and use the link as a reference. –  Phil Greer Oct 29 at 1:41
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Phil Greer Oct 29 at 1:41
    
Please don’t add just a link as answer to a question. If the link breaks, the answer you provided will not be useful for future visitors. Provide an answer of your own and use the link as reference. If needed, you can block quote the content from your link. More information is found in our help center, especially How do I write a good answer –  Benny Skogberg MCSA Oct 29 at 6:35
up vote 0 down vote accepted

"As most of you know , SP2013 Newsfeed provides a cool feature wherin you get a Video thumbnail and an embedded player for links that you post from youtube. In most of the cases it works, but in some cases wherein you use a proxy server, this functionality doesn’t work. I tried to look at documentation on technet, but as usual nothing.

Solution:

So there are 2 stages to resolve this issues

  1. Application Pool account needs access to the Internet

Login to the WFE’s servers on your SP2013 Farm and then put in the proxy information, so that the account is able to access the internet. Test it by visiting, https://youtube.com. Repeat this step on all WFE’s. This resolves part of the error and you are now able to connect to gdata.youtube.com to get thumnail information and SP Attachement class is now able to build the complete JSON object. However, the video thumbnail will still not work because the SP Farm needs to trust the website using the *.google.com certificate

  1. Enable Trust between SPFarm and Youtube.

On one of the WFE server, visit https://youtube.com and on the IE Browser, click on the lock icon in the address bar and download the certification(by clicking on details–>Copy to File, accept the defaults and store it on the local computer of your WFE server with yourfilename.cer).

Once you have this cert go to Central Administration–>Security–>Manage Trust, click new, give it some name and browse to the cer file you just downloaded and click OK.

Once this is done, go to you cer file on your local computer, double click it, Install Certificate and just follow the default prompt, the import will add the Certificate in your trusted root. Make sure to use Local Computer and not local user.

Repeat Step 1 and 2 on all of your WFE servers in the SP Farm.

Go back to your site and now the video embedded URL’s should be working"

Copied from the link shared by user 34659. It was wrong to just post a link, but it was indeed the solution for the problem. Thanks!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.