Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We are trying to publish a basic InfoPath Forms Services form for list with a very large number of columns - we think this might be the problem, but not sure. Here is the publish error:

"The SOAP message cannot be parsed"

Here is the data from the ULS log:

03/07/2013 11:05:03.86  w3wp.exe (0x042C)                           0x1690  InfoPath Forms Services         Runtime                         42fc    High        Can't parse solution ID:    f2d89f42-be70-4bcc-a4a1-f8736ef7ac84
03/07/2013 11:05:03.86  w3wp.exe (0x042C)                           0x1690  InfoPath Forms Services         Runtime                         fvf8    Assert      Form databind failed: There has been a critical error while processing the form. StackTrace:   at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.AddedControl(Control control, Int32 index)     at Microsoft.Office.InfoPath.Server.Controls.WebUI.BrowserFormWebPart.AssignFiles(Boolean ignorePostbackDataOnInit)     at Microsoft.Office.InfoPath.Server.Controls.WebUI.BrowserFormWebPart.EnsureDataBinding()     at System.Web.UI.Control.OnPreRender(EventArgs e)     at Microsoft.SharePoint.WebPartPages.WebPart.OnPreRender(EventArgs e)     at System.Web.UI.Control.PreRenderRecursiveInternal()     at System.Web.UI.Control.PreRenderRecursiveInternal()     at System.Web.UI.Control.PreRenderRecursiveInternal()     at System.Web.UI.Control.PreRenderRecursiveInternal()     at System.Web.... f2d89f42-be70-4bcc-a4a1-f8736ef7ac84
03/07/2013 11:05:03.86* w3wp.exe (0x042C)                           0x1690  InfoPath Forms Services         Runtime                         fvf8    Assert      ...UI.Control.PreRenderRecursiveInternal()     at System.Web.UI.Control.PreRenderRecursiveInternal()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)     at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)     at System.Web.UI.Page.ProcessRequest()     at System.Web.UI.Page.ProcessRequest(HttpContext context)     at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()     at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)     at System.Web.HttpApplication.PipelineStepManager.ResumeSteps(Exception error)     at System.Web.HttpApplication.BeginProcessRequestNotificati...  f2d89f42-be70-4bcc-a4a1-f8736ef7ac84
03/07/2013 11:05:03.86* w3wp.exe (0x042C)                           0x1690  InfoPath Forms Services         Runtime                         fvf8    Assert      ...on(HttpContext context, AsyncCallback cb)     at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)     at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)     at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)     at System.Web.Hosting.PipelineRuntime.ProcessRequestNotificationHelper(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)     at System.Web.Hosting.PipelineRuntime.ProcessRequestNotification(IntPtr managedHttpContext, IntPtr nativeRequestContext, IntPtr moduleData, Int32 flags)     f2d89f42-be70-4bcc-a4a1-f8736ef7ac84
03/07/2013 11:05:03.86  w3wp.exe (0x042C)                           0x1690  SharePoint Server               Unified Logging Service         c91s    Monitorable Watson bucket parameters: SharePoint Server 2010, ULSShipAssert12, fvf8, 14.0.6029.0    f2d89f42-be70-4bcc-a4a1-f8736ef7ac84

Does anyone have any idea how to fix this? It appears to be a bug inside InfoPath form services.

Update: deleting the InfoPath Form and reverting back to SharePoint works, but trying to create a new InfoPath forms fails with the same error.

Update: InfoPath works fine on the server and this form was working OK when there was ~60 fields instead of ~180 fields.

Update: I saved the list as (an empty) template and was able to recreate the list and customize it in InfoPath... so it seems it could be also be related to the amount of data in the list as well.

share|improve this question
add comment

3 Answers

It is confusing what you describe...

IMO, it is impossibe to publish Infopath template of Sharepoint List Form if:

Also, I would have tried to increase the Data Connection Response Size

Update:
I could have also referenced to size and number limits but they are more rigid from sharepoint side and since you probably created the Infopath form from existing sharepoint list by pressing "Customize" button on ribbon, they would have been useless.

share|improve this answer
    
Thanks for your answer: InfoPath Form Services works fine on the server - just not for this large list. I increased all the IPFS settings ten-fold in Central Admin, however the error still occurs. I have had to delete and recreate InfoPath forms before to fix an error - hence why I did it here. –  PeterX Mar 7 '13 at 23:40
    
Sure, you had to delete the prev one after changing settings if it prevented/blocked to do anything. Glad you have coped –  Gennady Vanin Novosibirsk Mar 8 '13 at 3:43
    
As per my update above - it seems existing data/list size could play a part in the error. There are approximately 1000 items in the existing list. –  PeterX Mar 11 '13 at 0:42
add comment
up vote 0 down vote accepted

Thanks to Daniel Yang on my TechNet post - as I suspected, I need to increase the IIS executionTimeout configuration as per this article.

I will run this after hours and report any issues back.

Update: It worked - I needed to increase the timeout to 6 minutes (360 seconds) for it to work. 240 seconds wasn't enough. Fortunately subsequent saves are faster, but ideally we'll archive off some old items.

share|improve this answer
add comment

Make sure that the InfoPath form Template is not checked out in SPDesigner. This was the problem which I had.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.