SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MOSS 2007 site set to use a master template called Awesome.master

I recently updated this template to change the <body> tag, and that worked fine but the changes have not taken effect for pages such as Document Libraries and Polls:

I can tell from looking at the HTML returned for these pages that it is not using Awesome.master, because it not only using the old format <body> tag but it's also missing the Google analytics code that was added to the master template a few months back. This applies to all the subsites I changed the master template for, but only for pages like Document libraries and polls.

I can't tell is where the page is getting its formatting from; is there some special master template setting for "built in" pages like viewing a document library? How do I find what template is being used and adjust the <body> tag as needed?

share|improve this question
You are sure that you checked 'Reset for all subsites' in the MasterPage configuration in Site Settings, right? – Daniel Ziga Aug 30 '11 at 11:47

SharePoint Designer is a good tool for figuring out what is going on here, even in the 2007 version. Look at the Page directive of AwesomeSite.aspx and check the MasterPageFile attribute. This will usually have an aliased master page such as ~masterurl/default.master or for publishing pages it will be ~masterurl/custom.master. This maps to the actual master page and can be set in SPD or programmatically.

It is also possible for this attribute to be set to a specific master page, e.g. /_catalogs/masterpage/custom.master, without the tilde alias. In this case changing the master page setting for the site will have no effect because it is hard-coded to that particular master page.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.