SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I already Installed Microsoft .Net Framework 4.5 in Windows Server 2012 Release Candidate Data Center using Features. but When i started to install SharePoint 2013 then it gives following error.

Setup is unable to proceed due to the following error(s): This product requires Microsoft .Net Framework 4.5

if I am trying to reinstall then it show that its already installed.

any solution for this error..?

share|improve this question

As mentioned by @jubblerbug, this can occur if you already have .NET Framework 4.6 installed before SharePoint 2013 (e.g. if you installed Visual Studio 2015 first). I couldn't use Microsoft's workaround as the option to remove .NET Framework 4.5 was disabled, and the ability to uninstall the .NET 4.6 update wasn't there either. So I used Process Monitor to examine what setup.exe was doing and work out the least invasive way to get around the issue.

WARNING: This method is completely unsupported and should be used on development environments only. Wait for Microsoft to correct the issue before applying to Staging or Production environments.

  1. Run regedit.exe as administrator
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4
  3. Right-click the v4 node, click Export, and save the export file somewhere safe - you will need it later
  4. Right-click the v4 node and click Permissions
  5. Click Advanced
  6. Change the Owner to your administrator account, tick "Replace owner on subcontainers and objects", and click OK
  7. Go through each node under v4 and:
    1. Right-click the node and click Permissions
    2. Set your administrator account to have Full Control and click OK
    3. Change any Version value you find from 4.6.x to 4.5.x (I used 4.5.51209)
  8. Run setup for SharePoint 2013 until you see the "Run Configuration Wizard" screen
  9. Untick the option to run the configuration wizard and click Close
  10. Find the exported .reg file from earlier and double-click it
  11. Confirm Yes that you want to import it back to the registry
  12. Reboot and continue with your installation process
share|improve this answer

For me the issue was that I was using Server 2012 R2 and had .Net Framework 4.6 installed. Apparently SharePoint 2013 installer does not play well if you have that version installed, it's a known issue with MS but they haven't solved it yet https://support.microsoft.com/en-us/kb/3087184.

I managed to solve it myself by following this blog post: http://geekswithblogs.net/bjackett/archive/2015/07/28/be-careful-installing-.net-4.6--visual-studio-2015-with.aspx

Essentially by uninstalling a particular Windows Update, KB3045563 to be exact. I also made sure that any .Net 4.6 specific items in add\remove programs were removed.

share|improve this answer

I also ran into this trouble spot one day when I was installing SharePoint 2013 for a client.

Setup is unable to proceed due to the following error(s): This product requires Microsoft .Net Framework 4.5

So you need to check which version of .NET framework is installed on the server :

• Set-Location 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client'
• Get-ItemProperty -Path . | Select-Object Version

Then depending on the version installed and the OS you're using, you need to uninstall the corresponding KB :

.NET Framework 4.6.1 : https://support.microsoft.com/en-us/kb/3102436

  1. Windows 8 ou Windows Server 2012 : KB3102439
  2. Windows 8.1 or Windows Server 2012 R2 : KB3102467
  3. Windows 10 : KB3102495

.NET Framework 4.6 : https://support.microsoft.com/fr-fr/kb/3045560

  1. Windows 8 or Windows Server 2012 : KB3045562
  2. Windows 8.1 or Windows Server 2012 R2 : KB3045563
share|improve this answer

Probably you have an older version of .Net 4.5. Try to install the newest one.

http://blogbaris.blogspot.ch/2013/08/sharepoint-2013-installation-endless.html

share|improve this answer

The solution that worked for me:

  1. Open Windows Update
  2. View update history
  3. Find the KB number in "Microsoft .NET Framework 4.6.1 for Windows Server 2012 R2 for x64 (KB3102467)" enter image description here
  4. Open "Program and Features"
  5. Search for the KB (KB3102467) and uninstall it
  6. Now continue the installation of SharePoint
share|improve this answer

protected by Community Mar 11 at 3:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.