Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Currently we have a staff directory using the People Search Results page type. The problem is our intranet is set up so the url uses the machinename. We'll call my 'intranet' for the purposes here. Apple users weren't able to access the system at all until I added an Alternate Access Mapping to the web application pointing the fully qualified name to the url with the machine name. So now Apple users can access the intranet by going to http://intranet.server.local. They can interact with all features of the site except for My Sites. The reason is that the People Search page returns all URL's to pages using just the machine name (i.e. http://intranet/my/personal/) no matter what the root url is. How can I force the system to return the My Site urls using the fully qualified name of http://intranet.server.local/my/personal?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

In the short term, you could simply change the Alternate Access Mapping URL for the Default Zone of your MySite to be the FQDN of the MySite instead of the Machine name. If you absolutely must preserve the Machine Name reference for the MySite, you can always list the machine name under one of the other zones, like Intranet.

Bear in mind that it is never a good idea to reference any SharePoint site by machine name as that does not allow scaling, load balancing or fault tolerance. I would strongly recommend that you rework your farm to use only proper FQDNs instead of machine names. Doing so would also resolve your issue.

share|improve this answer
    
Thanks for the input. I'll try the first. Unfortunately it's not up to me to make the change in the second. I'm simply building out the site. I don't have any control over the server farm. People above me have decided that no matter what they want a single word to be used to access the site for as many people as possible –  LoneWolfPR Mar 5 '13 at 18:33
    
Thanks. The first solved my problem. –  LoneWolfPR Mar 5 '13 at 18:36
    
This is really one of those things that is better to get right at the start because once the site goes live people start depending on that URL and embedding it all over the place. If the URL has to change down the road due to scaling or even server failure then it means that untold links will break. If it simply fast access they are worried about, the network folks can configure it so that a single machine name will redirect to the FQDN. –  Dave Wise Mar 5 '13 at 20:25

On the Apple machine, go to System Preferences>Network and enter your domain name in the "Search Domains" field.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.