SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason the from address on the list or library notifications I get are always prefixed with an "Administration". although I have the from address set up as CustomerPortal@MyCompany.com in outgoing email settings in CA.

How do I configure it to just show "CustomerPortal@MyCompany.com" as opposed to "Administration #CustomerPortal@MyCompany.com#"?

Replace # with angular brackets.

share|improve this question

It's worth double checking if your sharepoint farm emails are stamped with "administration" by an email device such as Cisco ironport etc.. Check with your network and email server guys guys.

share|improve this answer

Use...

 StringDictionary Headers = new StringDictionary();
 Headers.Add("to",...);
 Headers.Add("from",..);
 Headers.Add("subject",..);

 SPUtility.SendEmail( SpWeb, Headers, "Body");
share|improve this answer
    
Thanks but use where and how exactly? – user7400 Mar 5 '13 at 18:25
    
Sorry I assumed you were using code. The only place the "From" is saved would be CA > Manage Web Applications > Select your webApp > General settings dropdown > outgoing email. If that pop up does show the address check if the 'from' you are receiving matchs that of the person who triggers the alert. Good Luck – user13186 Mar 5 '13 at 18:47
    
Yes, I know where the outgoing email settings are. Please read the question again to understand what I'm trying to ask. – user7400 Mar 5 '13 at 19:05
    
I do understand, I just said the CA bit to clearify that u did check by that exact webApp. That is also why I included the bit about finding out the email of the indvidual who triggers the alert. Do You use SPAlerts, WorkFlows, you don't specify what type of notifications you have set up on your lists (hence I originaly assumed custome code) – user13186 Mar 5 '13 at 19:09
    
I set up the notifications using my account and have it set to email my personal email account. – user7400 Mar 5 '13 at 19:36

As per my Knowledge the email address which sents Notification is the one set up on the outgoing email in CA. it will not sent notification based on someone@example.com. it will send notifications based on Display Name "Someone". So if you want to change display from "Someone" to "Somethingelse" you need to change display name in AD."Hope this clarify your question. if this is not the question then you have to modify your question in more understandable way.

share|improve this answer

This is an old post so it may not help anyone. i found it while looking for a solution (which I have still not found).

However, the prefix may be the name of the website.

So as it pertains to Issue\Tasks libraries who use the feature E-mail when Ownership changes... the e-mails come from..

sitename [outgoing@emailsettings.com]

Maybe this doesn't apply to you.. but you might double check the Site Name.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.