Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a number of Excel files attached to SharePoint 2010 records. Those with .xlsx extensions open quite happily and can be edited and saved back, but those with .xlsm (i.e. with embedded macros) only open in read-only mode and force the user to save as a different name.

Is there any way around this?

share|improve this question
add comment

1 Answer

These settings are specific to Excel installed on the users machine, not SharePoint. If you go to the Excel options and go to Trust Center > Trust Center Settings you can modify this. There are multiple ways to modify this for your needs. You can trust publishers, trust locations, turn off protected view, etc. I'd play with these settings until you find a configuration that suits your needs and that you are comfortable with security-wise.

share|improve this answer
    
Thanks John. I'll have a play... –  Eddie Davies Mar 5 '13 at 15:35
    
OK, by editing the trust settings I have managed to remove an annoying message on openening the file (so I know this is working), but I still cannot get the file to open other than read-only, and thus cannot save (without re-naming). Additionally, I have some documents on a similar SharePoint repository but which were created with 2007, not 2010, and these claim to open in read-only mode but allow saing quite happily - so the difference must be in SP, not in Excel... –  Eddie Davies Mar 5 '13 at 16:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.