Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've been reading up on new SharePoint 2013 features, and continuous crawl plus the new Content Search Web Parts will do wonders for our SharePoint project. However, by default the Continuous Crawl is set to every 15 minutes, which isn't short enough for our project.

Everything I've been reading says that you can shorten this time via PowerShell, but I haven't found any reference to what PowerShell cmdlet needs to be run or what parameters to enter to make this change. If anyone has found out how to programmatically change the Continuous Crawl time I'd appreciate the help.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Have you tried the following?

$ssa = Get-SPEnterpriseSearchServiceApplication
$ssa.SetProperty("ContinuousCrawlInterval", 1)
share|improve this answer
    
This looks like it would do it, but it's been about 3 minutes after setting it and my web part hasn't caught the new item I created. Is there any kind of update I need to call via PS after I run the SetProperty? On an aside, I do subscribe to your blog via RSS, but my company blocks it as malware due to misconfigured DNS. Kind of a weird place to let you know but I figure since I got you here I might as well let you know! –  EHorodyski Mar 5 '13 at 22:25
    
After another attempt of disabling/enabling Cont. Crawling and then running your script it seems as if it worked. I think the next step for us is to optimize our content searches so we can crawl several places at once in a shorter time. Thanks again. –  EHorodyski Mar 6 '13 at 15:26
add comment

You would use the Set-SPEnterpriseSearchCrawlContentSource cmdlet. Here is the documentation on how to use it: http://technet.microsoft.com/en-us/library/ff607675.aspx(v=office.15).

share|improve this answer
    
And I believe it is the CrawlScheduleRepeatInterval parameter you need to specify. –  John Chapman Mar 4 '13 at 16:00
1  
Set EnableContinuousCrawls to true. And then it should follow the value you set to the incremental interval. –  John Chapman Mar 4 '13 at 16:23
    
I did a quick readthrough of that and it looks like you can only enable continious crawl there. CrawlScheduleRepeatInverval sounds like the right parameter, but it looks like you can only set ScheduleType to Full or Incremental –  EHorodyski Mar 4 '13 at 16:26
    
Looks like that isn't working. I'm running this command: Set-SPEnterpriseSearchCrawlContentSource -EnableContinuousCrawls 1 -CrawlScheduleRepeatInterval 2 Maybe I'm missing something? I apologize for not being very proficient with PowerShell so I can kind-of navigate through that TechNet article but putting it all together I'm not so great at. –  EHorodyski Mar 4 '13 at 18:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.