Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've created a site that serves as a service portal. It requires a customer to login, so when accessing the home page, when not authenticated, you'll get redirected to the login page. On the site anonymous access is enabled as the customers don't need to login to SharePoint itself.

When I access the home page from the localhost or any other machine in the intranet everything works fine. (Going to http://sharepoint/ and this will automatically redirect to http://sharepoint/SitePages/Home.aspx)

When trying to access the SharePoint from the outside e.g. http://helpdesk.company.com. I get the following page: http://helpdesk.company.com/_layouts/15/start.aspx#/SitePages/Home.aspx This page appears to be empty and when clicking the Home link, I remain on this page.

When I remove /_layouts/15/start.aspx# from the URL it navigates to the correct page where I putted my web parts.

Does anyone know why its behaving like this?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

i think what your refering to is Minimal Download Strategy feature.

Its purpose is to speed things up by loading as little resources as possible.

Minimal download strategy (MDS) is new web technology used in SharePoint 2013 to save the bandwidth traffic and quick render the pages to the clients.

MDS technique use a single .aspx page (/_Layouts/start.aspx) for your pages, with the actual URL encoded in the text following the hashmark ('#').

When navigating from page to page, only the changes between two compatible pages will be downloaded. Fewer bytes will be downloaded and the page will appear more quickly and avoid calling the server to download objects.

http://www.megren.net/Blog/Lists/Posts/Post.aspx?ID=40

to enable and disable the feature:

Site settings > under Site Actions section > manage site feature

enable/disable min download strat feature

I highly recommend you look at this, it goes into detail about it and what you need to do to incorperate it with your site :)

http://www.wictorwilen.se/sharepoint-2013---introduction-to-the-minimal-download-strategy-mds

share|improve this answer
    
What a great feature! Minimize Download sizes and maximize page load speed by... NOT LOADING ANYTHING! ;) –  Mzn Apr 7 at 8:23

Add your URL for sharepoint to 'trusted sites' in IE. I had same issue, it worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.