Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I’ll go straight to the point here, with the information I have. This is the first time I have set search on a multi tier farm, so I could have missed alot...

I am setting up search on a existing web server. The farm consists of a SQL Server(Probably not just 1), 2 app servers and 2 web front end servers.

A bit more about how I set it up:

Servers:

  • Server1: APP datasenter 1
  • Server2: Frontent datasenter 1
  • Server3: APP datasenter 2
  • Server4: Frontend datacenter 2

The Frontend servers run within a DMZ(load balanced), and it’s very restricted access back to the app servers.

Alternate Access Mappings:

The frontend serves host a extended web application (www.domain.com). (For anon access) The app servers host publisher access (publisher.domain.com)

Both run on port 80.

Search Status:

  • Crawl status Online for crawling
  • Background activity Computing ranking
  • Recent crawl rate 0.00 items per second
  • Searchable items 707
  • Recent query rate 1.00 queries per minute
  • Propagation status Idle
  • Default content access account DOMAIN\ACCOUNT-05
  • Contact e-mail address someone@example.com
  • Proxy server None
  • Scopes update status Idle
  • Scopes update schedule Automatically scheduled
  • Scopes needing update 0
  • Search alerts status Off Enable
  • Query logging On Disable

Crawl History:

Content Source Type Start Time End Time Duration Success All Errors hostname.com Full 2/28/2013 9:38 AM 2/28/2013 9:44 AM 00:05:20 1,581 0

Search Application Toplogy:

  • Admin: Server3.
  • Crawl: Server 3.
  • Databases: All on the SQL Server.

Index Partition:

  • Server1 and Server 2. (App Servers)

Services:

Server1 and 3:

  • Microsoft SharePoint Server 2010
  • Microsoft SharePoint Foundation Web Application
  • Microsoft SharePoint Foundation Workflow Timer Service
  • Search Query and Site Settings Service
  • SharePoint Server Search

Server 2 and 4: Same, but not SharePoint Server Search.

Search setup:

Server Name Mappings:

In addition, added a lot of rules, and a Scope witch only takes sites made from certain content types.

Enabled feature: Search Server Web Parts

Added Search Box Web Part and Core Results Web Part.

It works to search when logged into the app servers directly on the publisher web application, but it does not work when accessed through www (ether directly on the servers’ remote, or via the public web address).

When I search on the www server, I get Correlation ID with these errors:

Name=Request (GET:http://www.domain.com:80/en/search/Pages/default.aspx?k=test&key=1&s=CustomScope)

Leaving Monitored Scope (PostResolveRequestCacheHandler). Execution Time=8.92683287959783
Setting [Display] as the FormContext.FormMode for the current page
FetchDataFromURL start at(outside if): 1 param: start

Internal server error exception: System.NullReferenceException: Object reference not set to an instance of an object.    
 at Microsoft.Office.Server.Search.WebControls.CoreResultsWebPart.ConfigureDataSourceProperties()    
 at Microsoft.Office.Server.Search.WebControls.SearchResultsBaseWebPart.EnsureWebpartReady() System.NullReferenceException: Object reference not set to an instance of an object.    
 at Microsoft.Office.Server.Search.WebControls.CoreResultsWebPart.ConfigureDataSourceProperties()    
 at Microsoft.Office.Server.Search.WebControls.SearchResultsBaseWebPart.EnsureWebpartReady()


Watson bucket parameters: SharePoint Server 2010, ULSException14, 06175311 "sharepoint server search", 0e00178d "14.0.6029.0", 17853a8f "microsoft.office.server.search", 0e0017f1 "14.0.6129.0", 5087b621 "wed oct 24 12:34:25 2012", 000032bb "000032bb", 00000097 "00000097", 4a6d3421 "nullreferenceexception", 67316a39 "g1j9"

A runtime exception was detected. Details follow.  Message: Thread was being aborted.  Technical Details: System.Threading.ThreadAbortException: Thread was being aborted.    
 at System.Threading.Thread.AbortInternal()    
etc

(Watson Reporting Cancelled) System.Threading.ThreadAbortException: Thread was being aborted. 

To try to fix the error, after readint some technet whitepaper; I tried to add the two frontend servers as query servers, and I got this error after a bit over 1 hour:

Errors were encountered during the configuration of the Search Service Application. 

Microsoft.Office.Server.Search.Administration.SearchConfigWizard+SearchConfigWizardException  : Topology provisioning failed due to an error.Topology activation was aborted because of   Microsoft.Office.Server.Search.Administration.QueryComponentTransitionException:   System.IO.IOException: The network path was not found. at     System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at   System.IO.Directory.InternalCreateDirectory(String fullPath, String path, DirectorySecurity   dirSecurity) at     Microsoft.Office.Server.Search.Administration.CopyFilesJob.Initialize() at   Microsoft.Office.Server.Search.Administration.CopyFilesJob.Execute(Guid targetInstanceId)   at   Microsoft.Office.Server.Search.Administration.QueryComponent.CopyBigIndexFiles(QueryComponen  t component) at   Microsoft.Office.Server.Search.Administration.QueryComponent.ExecuteCurrentStage(). To     retry the activation, run the cmdlet Set-SPEnterpriseSearchQueryTopology -Active. If the    error persists, restart the activation by calling the CancelActivate() method on the query   topology object, and then calling Set-SPEnterpriseSearchQueryTopology -Active. at   Microsoft.Office.Server.Search.Administration.SearchConfigWizard.WaitForTopologyTimerJobToFi  nish() at   Microsoft.Office.Server.Search.Administration.SearchConfigWizard.UpdateSearchApp() at   Microsoft.Office.Server.Search.Administration.SearchConfigWizard.ProvisionSearchServiceAppli  cation() at   Microsoft.Office.Server.Search.Administration.SearchConfigurationJobDefinition.ExecuteTimerJ  ob()
2/28/2013 2:21:27 PM 

Anyone got any Idea on what to do here? Much appreciated!

Error in ULS after reinstall of Search Service:

    SearchServiceApplicationProxy::Execute--Error occured: System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: The network path was not found. (Exception from HRESULT: 0x80070035) (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is: System.IO.FileNotFoundException: The network path was not found. (Exception from HRESULT: 0x80070035)   
 at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)    
 at Microsoft.Office.Server.Search.Query.KeywordQueryInternal.Execute()   



    SharePoint Web Services Round Robin Service Load Balancer Event: EndpointFailure Process Name: w3wp Process ID: 3580 AppDomain Name: /LM/W3SVC/1376075679/ROOT-1-130065709837059833 AppDomain ID: 2 Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:32d5d1289d234b5b9465b1a63ec1e5ef#authority=urn:uuid:ab453f25b6e241759aad2006097374ed&authority=https://server3p:32844/Topology/topology.svc Active Endpoints: 1 Failed Endpoints:3 Affected Endpoint: http://server2p:32843/32d5d1289d234b5b9465b1a63ec1e5ef/SearchService.svc

Exception when fetching results: System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: The network path was not found. (Exception from HRESULT: 0x80070035) (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is: System.IO.FileNotFoundException: The network path was not found. (Exception from HRESULT: 0x80070035)   
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)        
share|improve this question
    
I suppose there are strict firewall rules implemented between all these servers? Might want to look at these I think. Also, did you install KB976462? –  Thomas Vochten Feb 28 '13 at 14:12
    
Yes, only requested ports are opened. Is search using any particular ports that needs to be open? I will check if the KB is installed, thank you! Do you know if Index partition should be installed on the WFE servers? Mirrored or moved? –  user1217169 Feb 28 '13 at 14:20
    
I can't see that KB976462 is installed, you highly recomend to test that to see if it can fix the problem? –  user1217169 Feb 28 '13 at 14:33
    
I would indeed recommend to ask if it is installed. –  Thomas Vochten Feb 28 '13 at 14:49
    
The index partition can be installed anywhere (on the web servers is a good place) as long as the queries can travel from the web server to the query service. Having a mirror is not needed to just be able to search. –  Thomas Vochten Feb 28 '13 at 14:51
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.