Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have carried out a fair share of SharePoint 2007/2010 installations over the years, but always in Farm mode, never in stand-alone mode. As our main database server is not yet upgraded to a version of SQL Server that is compatible with SP2013, I carried out several SP2013 test installations in stand-alone mode on a domain joined Windows Server 2012 system. One of the things I noticed is that when I do this the "SharePoint Administration" Windows Service is never started automatically and is set to "Manual start-up". All other SharePoint services are set to Automatic and start up without error.

The problem is recurring and happens every time I deploy SharePoint 2013 in stand alone mode. I have not tried a 'Farm' deployment yet.

So, my question is this: Is this a side effect of running in stand-alone mode, or is this something that has changed in SharePoint 2013? If it is the latter, why has this change been made as it affects the deployment of WSP files.

Update: I have to care about this as we develop commercial SharePoint software. It is an easy fix on our own test system, but we need to know what to expect on our customer's systems.

share|improve this question
add comment

1 Answer 1

I got that as well in one standalone installation of SharePoint 2010 and had it the only time that I tried standalone (back to the customer preview) in 2013. The SPAdminV4 service rollbacks to manual start as soon as the configuration wizard will run but you didn't specify if you got it only once (and changing it manually fixed it) or if it's recurrent

Other people noticed similar behavior of that service : http://social.msdn.microsoft.com/Forums/en-US/sharepointdevelopment/thread/209c7f34-7b1c-435c-9784-3af52a985ccf/

Make sure that this account is running under the local system account and check-out the log when the server reboots to see what would prevent it from starting automatically.

In the long run, do not spent too much time struggling with stand alone mode. You know the limitations and it will take much less time to setup a local domain on your VM if you're not part of it (even if we know installation on a DC is neither supported) and follow the farm installation using SQL Server 2008 R2 Express or SQL Server 2012 Express (installed previously and accessed through an alias, but that's another story !) You'll run into much less trouble than this unreliable standalone installation (even with RTM, you'll still have issue as it was never designed to run with local accounts) (and you could run the farm configuration wizard to quickly get all service application up & running if it's just to discover SP2013).

(Edit : added suggestion for farm configuration wizard to get quick result)

share|improve this answer
    
Hi Francois, I implied it is recurring ("never started automatically"), but I'll update the text to make it more clear. I have to worry about this as we write commercial SharePoint software that is deployed on thousands of servers all over the world. It needs to work perfectly on all of them and, believe it or not, there are production environments that run like this. Many people evaluate our software in Stand-Alone Dev environments installed like this as well and they need a first class experience. –  Muhimbi Feb 27 '13 at 13:06
    
Understood, thanks for the clarification. Do you still have the issue after a reboot or running the SharePoint 2013 product configuration wizard ? You installed all the required KB before installation ? I quickly scan through the official deployment guide for standalone installation but saw nothing, it should be started but as stated, I got issue with the 2013 CTP and also in 2010). –  Francois Verbeeck Feb 27 '13 at 14:22
    
The Service is set to "manual", so restarting won't change anything. The Product Configuration wizard has been run at this point as well. All SP2013 prerequisites have been installed using the wizard and SharePoint has been installed using the standard installer with the 'Stand alone' option selected. At this moment all I need to know if this is the default behaviour of SP2013 and if it is the same when doing a Farm install. –  Muhimbi Feb 27 '13 at 14:31
    
That's not the same when doing farm install. Right now I have around 10 environments in SP2013 (farm installation), all of them having the SPAdminV4 configured properly and starting automatically without issue. (and there is a mix of SP2013 Standard and SP2013 Enterprise although it won't change, foundation should behave the same) –  Francois Verbeeck Feb 27 '13 at 15:47
    
So how were these farm installations deployed? Using sharepointinstaller.codeplex.com? Or did someone carry out a manual step to enable the Administration Service or was this service enabled automatically by the standard SharePoint installer? –  Muhimbi Feb 27 '13 at 16:16
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.