SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to fix some missing server side dependencies on an SP2010 farm and am having trouble with missing webparts.

There are two problems specifically.

1) Of the pages I can find (two pages with supposedly 4 instances of the same webpart), when looking at webpart maintenance for the page, there are no error webparts.

Solved This was caused by sharepoint designer. Deleting one page and recreating the other has solved this by removing page history maybe.

2) There are still 4 instances of webparts that are not tracible. I have looked in the database and can see there are tp_PageUrlID values for the webparts, but when I do an inner join on the alldocs table, it is clear that some of these pages dont exist.

I have also cleared the site recycle bins to no avail.

Has anyone had experience with this issue in the past?

Thanks in advance.

I have added recent advances to this question.

share|improve this question

Don't know if you have already checked, but it won't hurt to add this.

If you have already checked for istance of the web part on your site collection pages it may be worth a try to check for stale web part templates istance in the gallery. If some removed/deactivated feature left a .webpart (or .dwp etc) file in the gallery and that file now points to a missing class/assembly, you will still get a missing reference warning, even if the web part is not actually used.

You can just remove the file from the gallery and it won't affect the rest of the site. Anyway, if you discover that this was the problem you can consider in the future to alter the solution/features that provisioned the problematic web part so that it performs appropiate clean up. An classical example would be deleting the .webpart templates from the gallery when the web part feature is deactivated.

share|improve this answer
I did actually have that issue before. It came up under missing setup files for the health analyzer. Thanks though. – John S Feb 25 '13 at 15:45
up vote 0 down vote accepted

Unfortunately, working with MS on this issue showed that besides recreating the entire farm, there isnt a way to fix this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.