Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a custom listform template with some logic. See also: How to use your own custom ListItem template for Display, Edit, and New

I implemted also something like this:

http://msdn.microsoft.com/en-us/library/aa543922%28v=office.12%29.aspx

In Visual studio debug I can see my custom listform template when I create a new item in my custom list. When I deploy it on the same dev server, I can also see my custom listitem template.

I have created a wsp and deploy it on my test environment. I activated all the features. But I do not see my custom listitem template when I click on new item of my custom list.

I have tryed also to create a new list instance of my custom list, but didnt help.

I have do an uninstall and remove, and then deploy the wsp again, but did als not work.

This is my custom listitem template:

<%@ Control Language="C#"   AutoEventWireup="false" %>
<%@Assembly Name="Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<%@Register TagPrefix="SharePoint" Assembly="Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" namespace="Microsoft.SharePoint.WebControls"%>
<%@Register TagPrefix="ApplicationPages" Assembly="Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" namespace="Microsoft.SharePoint.ApplicationPages.WebControls"%>
<%@Register TagPrefix="SPHttpUtility" Assembly="Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" namespace="Microsoft.SharePoint.Utilities"%>
<%@ Register TagPrefix="wssuc" TagName="ToolBar" src="~/_controltemplates/ToolBar.ascx" %>
<%@ Register TagPrefix="wssuc" TagName="ToolBarButton" src="~/_controltemplates/ToolBarButton.ascx" %>
<%@ Register TagPrefix="myCompany" Assembly="myCompany.ChangeManagement, Version=1.0.0.0, Culture=neutral, PublicKeyToken=92cf2084880c437e"  Namespace="myCompany.ChangeManagement.Common" %>

<SharePoint:RenderingTemplate id="ListFormChangeManagement" runat="server">
    <Template>
        <span id='part1'>
        <div><h1>My Custom template</h1></div>
            <SharePoint:InformationBar ID="InformationBar1" runat="server"/>
            <div id="listFormToolBarTop">
            <wssuc:ToolBar CssClass="ms-formtoolbar" id="toolBarTbltop" RightButtonSeparator="&amp;#160;" runat="server">
                    <Template_RightButtons>
                        <SharePoint:NextPageButton ID="NextPageButton1" runat="server"/>
                        <SharePoint:SaveButton ID="SaveButton1" runat="server"/>
                        <SharePoint:GoBackButton ID="GoBackButton1" runat="server"/>
                    </Template_RightButtons>
            </wssuc:ToolBar>
            </div>
            <SharePoint:FormToolBar ID="FormToolBar1" runat="server"/>
            <SharePoint:ItemValidationFailedMessage ID="ItemValidationFailedMessage1" runat="server"/>
            <table class="ms-formtable" style="margin-top: 8px;" border="0" cellpadding="0" cellspacing="0" width="100%">
            <SharePoint:ChangeContentType ID="ChangeContentType1" runat="server"/>
            <SharePoint:FolderFormFields ID="FolderFormFields1" runat="server"/>
            <%--<SharePoint:ListFieldIterator ID="ListFieldIterator1" runat="server"/>--%>
            <myCompany:ChangeManagementListFieldIterator ID="MyChangeManagementListFieldIterator" runat="server" />
            <SharePoint:ApprovalStatus ID="ApprovalStatus1" runat="server"/>
            <SharePoint:FormComponent ID="FormComponent1" TemplateName="AttachmentRows" runat="server"/>
            </table>
            <table cellpadding="0" cellspacing="0" width="100%"><tr><td class="ms-formline"><img src="/_layouts/images/blank.gif" width='1' height='1' alt="" /></td></tr></table>
            <table cellpadding="0" cellspacing="0" width="100%" style="padding-top: 7px"><tr><td width="100%">
            <SharePoint:ItemHiddenVersion ID="ItemHiddenVersion1" runat="server"/>
            <SharePoint:ParentInformationField ID="ParentInformationField1" runat="server"/>
            <SharePoint:InitContentType ID="InitContentType1" runat="server"/>
            <wssuc:ToolBar CssClass="ms-formtoolbar" id="toolBarTbl" RightButtonSeparator="&amp;#160;" runat="server">
                    <Template_Buttons>
                        <SharePoint:CreatedModifiedInfo ID="CreatedModifiedInfo1" runat="server"/>
                    </Template_Buttons>
                    <Template_RightButtons>
                        <SharePoint:SaveButton ID="SaveButton2" runat="server"/>
                        <SharePoint:GoBackButton ID="GoBackButton2" runat="server"/>
                    </Template_RightButtons>
            </wssuc:ToolBar>
            </td></tr></table>
        </span>
        <SharePoint:AttachmentUpload ID="AttachmentUpload1" runat="server"/>
    </Template>
</SharePoint:RenderingTemplate>

This is my custom content type:

<?xml version="1.0" encoding="utf-8"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
  <!-- Parent ContentType: Item (0x01) -->
  <ContentType ID="0x0100839f032740084ac2ae6ea6ab45928a65"
               Name="myCustomContentType"
               Group="myCompany CMP"
               Description="myCustomContentType"
               Inherits="FALSE"
               Version="0">
    <FieldRefs>
      <FieldRef ID="{427E04A8-45E5-4243-BFE9-5FDF6FC6205B}" Name="RFCState" ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{EBC17A5D-F320-43D0-A275-7C657EA6F6C9}" Name="RFCDescription"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{76BF7D5B-6A12-48D1-9827-ADE990B03216}" Name="RFCCompany"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{9C9ED55A-7025-47F4-9637-27D5D2A1BCAE}" Name="RFCDepartment" ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{87DA58EB-3C70-4EF4-B833-1D4A93D60AC9}" Name="RFCClient"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{56398822-7A4F-4155-A875-ADD09F32D4F2}" Name="RFCContact"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{A5A5CA1A-6CF4-4BA7-B650-7F06910EA0CD}" Name="RFCAppliesTo"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{47705F89-4883-4AD5-8495-98CE1D4B5C35}" Name="RFCDescriptionCurrent"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{F61E42BC-AEC0-43AA-9AD2-AD7B36C60B22}" Name="RFCDescriptionNew"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{97CD7687-4F16-4AC5-9156-1F178037B5D1}" Name="RFCRisks"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{D424D1B4-4CEA-4E47-B843-6B746EAD1E35}" Name="RFCDemands"  ShowInEditForm="TRUE" ShowInNewForm="TRUE" ShowInDisplayForm="TRUE"/>
      <!-- These are 5 fields only visible in edit mode-->
      <FieldRef ID="{09B7ED41-C5D0-4B8F-B102-F698164A05B9}" Name="RFCExpertise"  ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{1A64CE4A-716C-4572-B344-E7CCFE443D50}" Name="RFCScope"  ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{B131BD67-6B1E-4A40-A916-7C8D9CD17792}" Name="RFCExpectedEffort"  ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{39BC744E-08D4-410C-9D66-B728221634F5}" Name="RFCOperatingCosts"  ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{708B111D-F1B2-43BC-89B1-BDFF36C1DB4C}" Name="RFCMotivationAssessment"  ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{C95F5617-0C01-49F2-AA5C-8ADE757901F4}" Name="RFCPriority"  ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{D6E32A83-D6FD-431B-B2CB-625516D3935F}" Name="RFCDatePlanned"  ShowInEditForm="TRUE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>

      <FieldRef ID="{F7788EA8-A6AD-4009-956A-E756E64D67CC}" Name="RFCImpactanalyses" ShowInEditForm="FALSE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
      <FieldRef ID="{DB7133D3-96E6-48C5-8B69-76B208FFA5FD}" Name="RFCStatusChanged" ShowInEditForm="FALSE" ShowInNewForm="FALSE" ShowInDisplayForm="TRUE"/>
    </FieldRefs>

    <XmlDocuments>
      <XmlDocument NamespaceURI="http://schemas.microsoft.com/sharepoint/v3/contenttype/forms">
        <FormTemplates  xmlns="http://schemas.microsoft.com/sharepoint/v3/contenttype/forms">
          <Display>ListFormChangeManagement</Display>
          <Edit>ListFormChangeManagement</Edit>
          <New>ListFormChangeManagement</New>
        </FormTemplates>
      </XmlDocument>
    </XmlDocuments>

  </ContentType>
</Elements>
share|improve this question
    
$ct = $w.ContentTypes["myCustomContentType"] $ct.DisplayFormTemplateName The value of this powershell commando is : ListForm. This is not what I am expecting. I am expecting my custom listform name: ListFormChangeManagement What is the problem? –  KHA Feb 22 '13 at 12:48

1 Answer 1

I have fixed this problem with a powershell commando, but I dont like it. If there is someone which has a better solution, please let me know:

 $w = Get-SPWeb -Identity "http://mySPEnvironment"
 $ct = $w.ContentTypes["myCustomContentType"]
 $ct.DisplayFormTemplateName = "ListFormChangeManagement"
 $ct.EditFormTemplateName = "ListFormChangeManagement"
 $ct.NewFormTemplateName = "ListFormChangeManagement"
 $ct.Update($true)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.