Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

How do i remove this column?

  1. I did create a new Content Type with Title, Nickname and Comments columns. I DID NOT choose the "CommentID" column. But it still gets there, how do i remove the site column? Are there any powershell scripts or something?

  2. Trying manually to remove is telling me that i have to remove the column from an content type, but i'm not using it in any content type.. enter image description here

share|improve this question

2 Answers 2

Most likely you are, basically everything in SharePoint is based on a Content Type, base one being the Item. Go for list/library settings, and in Advanced settings, choose Yes to "Allow management of Content types". As soon as you Save you should see the list of Content types added to your list.

They are basically the blueprint definition of your list/library. Once, done, click on the Name of the CT and you shall see another Page, having PARENT most likely the Exact same name - is confusing, because actually the CT on your list is an Instance of that one (its child).

Click again on the Parent and you shall be able to see the COLUMN you do not need. Here you have 2 choices:

  1. Mark it Hidden - which shall translate into this being hidden from User Interface, but still be part of the CT definition -just in case someone else is actually using that.
  2. Delete it completely -at it shall disapear from UI, discard completely all data and remove it from any place where it is used (!!!!)
share|improve this answer
    
i've already tried that and it works until i deploy with visual studio, then the column is back! I want to remove the column completely. –  Kristian Salov Feb 19 '13 at 12:02
1  
Perhaps there's something in your visual studio project that is adding it back? –  lgaud Feb 19 '13 at 12:29

What parent content type have you selected? It seems like this column appears, because it exists in the parent content type.

You can check it as follows:

Go to site settings / site content types and select your content type. You will see what is the source of each column.

share|improve this answer
    
Hi! When i go to site settings and choose my content type the "CommentID" does not exist.. Only the other three, title, nickname and comments. –  Kristian Salov Feb 19 '13 at 12:00
    
But when i go to list settings the "Comments222" exists, but i don't know where it comes from.. –  Kristian Salov Feb 19 '13 at 12:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.