Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a publishing site and copied the v4 masterpage then changed the style to hide the quicklaunch bar in v4 copy masterpage.

When I reverted the masterpage to v4 masterpage, the page is not rendered with quick launch bar. I did check in developer tools and found the css used to hide quick launch, though I did not modify any thing in v4 masterpage.

Even I created a new publishing site with v4 master, I am still not able to render quick launch there.

Please point me to resolve the issue.

share|improve this question
add comment

1 Answer

So, I hope I understood you correctly:

1) You changed Masterpage style to hide the quick launch bar

2) You changed it back to render the quick launch bar, but it is not rendered correctly ("old" behaviour).

I came to a slightly similar problem here. My Problem was, that I had to "approve" every change I made on the masterpage. Via UI it's in your SiteCollection (~site) and then something like this. /_catalogs/masterpage/Forms/AllItems.aspx

Then you see the library containing your changed masterpage. By clicking on the masterpage, you can approve it via ribbon menu item "approve/decline" or something liek that (using german version here).

As far as I remember there is a status for the masterpage shown in the list too, which shouldn't say "approved" but "due" or something like that (sorry, using german version here, in german it's "ausstehend", might be a little different than my translations here).

I hope this helps to solve your problem.

Best regards, Dominik

share|improve this answer
    
I've run into that one myself, sounds like the right fix for this situation. –  thanby Feb 19 '13 at 13:45
    
In English, "ausstehend" ("outstanding", literally) is displayed as "Pending". msdn.microsoft.com/en-us/library/… Ich liebe Deutsch. –  RJ Cuthbertson Feb 19 '13 at 15:15
    
Actually I created the copy of v4 master page and did changes in the copied master page. I approved the copied v4 master page and quick launch hiding worked fine. My problem was, when I create another new site with v4 master page, the quick launch was not rendered. When I see developer tools, it is showing quick launch hide css though I did not use that css any where in v4 master. I didn't modify v4 master page at all. –  anil kumar Feb 19 '13 at 16:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.