SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've changed a site content type and set it to update those that inherit from it. However, when I go to create a custom list form based on a list with one of those content types, SPD gives me the old fields. I've checked the list content type and it has all the changes I made, but I can't seem to make SharePoint Designer see them.

share|improve this question
up vote 0 down vote accepted

If you're creating the list in SharePoint Designer, you should refresh the Data Source Library after your change (or restart SPD). There's a refresh link at the bottom of the Data Source Library pane.

share|improve this answer
Thanks Marc. The list is a pre-existing list that uses the content type I've modified. I've tried both refreshing the Data Source Library and restarting SPD and combinations thereof, but it's had no effect so far. – Carlos Oct 5 '10 at 23:58
Do you see the changes to the Content Type on the list through the list settings in the UI? – Marc D Anderson Oct 6 '10 at 12:33
Yes, the content type is changed in the list settings. The old fields are gone and the new ones are present. If I open the NewForm.aspx, it reflects the content type correctly. It's only SPD that can't seem to see the changes in the content type. – Carlos Oct 6 '10 at 16:04
Hmm. You said you were creating a custom form. Any existing customized forms aren't going to pick up the changes to the Content Type. Once you have customized a form, you have to do that yourself. – Marc D Anderson Oct 6 '10 at 17:23
Okay, I think that explains it. I had added a little bit of code to the NewForm.aspx before we decided we needed to change the content type and layout of the form completely. If SharePoint Designer considered that customization, then I assume the copy of it I made would inherit that same issue. – Carlos Oct 6 '10 at 17:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.