Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a global workflow and added it to a SP 2010 site as a solution (which I have activated), but when I go to apply this workflow to my list/library the new workflow template is not in the list of possible workflows that I can select from.

Once I have added a workflow as a Solution to a site, how do I apply it to the list that I want to run the workflow against?

Thanks

Stephen

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Assuming you follow the procedure and created a "Globally Reusable Workflow" and not just a "Reusable Workflow" (just to be sure - have a look at the procedure here http://www.codeproject.com/Articles/70867/Reusable-and-Globally-Reusable-Workflows-in-ShareP) in addition to ensure in Site Collection is activated also open the Top-Level site via SharePoint 2010 Designer and under the Workflows node you should see in the Category "Globally Reusable Workflows" allong with others (might depend according to your settings), such as Approval, Collect Feedback, etc.

share|improve this answer
    
Is the Site Collection another feature/solution that needs to be activated. In the work enviroment I'm in I can't use SharePoint designer to look at anything except MySite, so I can't see the main site in SP Designer. –  stevo Feb 18 '13 at 12:00
    
you should at least see it at the Site Collection Features level –  C. Marius - MVP Feb 18 '13 at 12:04
    
I've looked at the Site Collection Features level and my workflow is not in this list. Not sure if the administrator for the main site has blocked this –  stevo Feb 18 '13 at 13:34
    
"Blocking it" - practically means not deployed the .wsp package –  C. Marius - MVP Feb 18 '13 at 16:13

Site Actions -> Site Settings -> Under Site Actions Group click Manage Site Features -> Then activate that workflow

share|improve this answer
    
OK, I've done that, but my workflow is still not accessible as a template in the workflow page, when I'm trying to setup a new workflow? Is there another step I need to do? –  stevo Feb 18 '13 at 11:54
    
Activate your solution in the top-level site through a sharepoint administrator account, and then activating that feature on your site which i think is what you've done already... so the first step you havent done yet.... i think :)\ –  JYR Feb 18 '13 at 12:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.