Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I set an anonymous access to home page in sharepoint 2010. but when i open page like

'http://servername/Sitepages/homepage.aspx'

, i working but when i open

http://servername/

, its not working. i set

http://servername/Sitepages/homepage.aspx

as home page

share|improve this question
    
when you say is not working i assume is not accessible at all, or for anonymous? –  C. Marius - MVP Feb 16 '13 at 7:33
    
when user click on home button, its asking for username and password.. –  Rajesh Joshi Feb 16 '13 at 7:43
add comment

1 Answer 1

up vote 2 down vote accepted

Just for the reference, make sure you follow all these steps http://www.topsharepoint.com/enable-anonymous-access-in-sharepoint-2010.

Basicaly you need to do this in Central Admin at the Web Application, then at the level of the site collection, and finally , you also need to configure Permissions to the site for anonymous users, exactly as described at the last step.

share|improve this answer
    
when we give permission to entire web, anonymous user can access and view all list and library –  Rajesh Joshi Feb 16 '13 at 7:54
1  
Normally yes - SitePages is a Library still, to access its pages you need permissions. In addition you could enable the LockDown (ViewFormPagesLockDown feature - not enabled by default in Collaboration site, only for Publishing), also see here c-sharpcorner.com/uploadfile/Roji.Joy/… –  C. Marius - MVP Feb 16 '13 at 8:00
    
Thanks... Its working –  Rajesh Joshi Feb 16 '13 at 9:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.