Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am running SharePoint Foundation in a two server farm. I set the farm up about a year ago and was only recently asked to enable site analytics for a particular web application. The 'Usage and Health data collection' service application was created when I initially set up the farm. When I click on the 'Manage' button for it, I can see the log files should be stored in the default location (../14/LOGS). When I look at this folder on either server, there are ~5400 log files there, but they are all 0kb in size. If you open any of them, they are empty.

Last week I deleted this service application and recreated it, but the problem still persists. In the web application, when you go to Site Settings - 'Site Web Analytics Reports', the following message is displayed:

A web analytics report is not available for this site. Usage processing may be disabled on this server or the usage data for this site has not been processed yet.

Thanks in advance

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

It might be that the service application is not properly created via user interface. Try using this to properly create it http://sharepointreporter.wordpress.com/2010/12/08/sharepoint-2010-usage-and-health-data-collection-service-application/

Once you validate they are started, you need to configure it as detailed here http://www.c-sharpcorner.com/uploadfile/shyjumohan/configure-web-analytics-and-health-data-collection-in-sharepoint-2010/

Only after all this is done, try again after the Job executes at least once

share|improve this answer
    
Thanks, after following the instructions in the links above the Service Application was configured correctly, but the Log files were still 0kb. I also noticed I was receiving no messages from ULS, followed bobgreen84's instructions at: social.technet.microsoft.com/forums/en-US/… and this resolved the problem. –  Lou Feb 15 '13 at 16:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.