Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am having the worst time connecting to the web service to call in the UserName variable for use in my InfoPath 2007 form. I can do it from a code behind, and want to be able to use this option as well.

I have created a new Data Connection Library in my site on SharePoint 2007 and uploaded my new udcx file. This file gleans data from GetUserProfileByName from ://SHAREPOINTBOX/_vti_bin/UserProfileService.asmx?WSDL. The udcx is approved in the library. From my machine named MACHINENAME, I am able to preview the form and the data connection works flawlessly. I can see my username in the required field.

BTW: I have been following instructions here: http://msdn.microsoft.com/en-us/library/ms772101%28v=office.12%29.aspx

When I upload the Full Trust form to SHAREPOINTBOX in the same site as my DCL, it fails with error 6932

I do have Allow user form templates to use authentication information contained in data connection files checked.

I also have Allow cross domain access…

Again, the form is Full Trust.

Here’s a bit of the Event:

The form could not retrieve data from ://sharepointbox/_vti_bin/UserProfileService.asmx because it would violate cross-domain restrictions. To allow this connection for administrator-approved form templates, enable full trust for the form template, or add the connection to a Data Connection Library. For user form templates, cross-domain connections must be enabled in SharePoint Central Administration, and all connections must be in a Data Connection Library. For more information, please see the security >documentation for InfoPath Forms Services. (User: ME, Form Name: MyFormName,

One more interesting part; while following directions from MSDN, each time I saved my udcx file, it left out the Title, thereby disallowing me from approving. I had to download the file and save it locally > delete the file in the Library and upload the one from my desktop. Then, it placed a Title in the correct required field and I was able to check in and approve.

Any ideas?

share|improve this question
    
Are the infopath data connections referencing the old environment (your machine)? –  Mike Apr 30 at 17:05
    
Thanks for the tip, Mike. I may have to look over this again. –  Sean May 2 at 15:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.