Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When i click on SharePoint "My Profile" it shows 404

It takes me to www.myserver/my/Person.aspx?accountname=abc

We use FBA authentication. How to fix it?

Regards,

Dhaval

share|improve this question

2 Answers 2

Seems like you didn't followed proper steps to set up User Profile Service application in your farm.

The possible problem could be that there isn't a site collection set up using the appropriate template in the MySite web application.

Check this Article on MSDN providing solution to your problem,

http://support.microsoft.com/kb/924399?wa=wsignin1.0

To resolve this issue, move the personal site provider for My Site personal sites to a different site location. To do this, follow these steps: Add an explicit inclusion included path for My Sites personal sites. To do this, follow these steps:

Start SharePoint 3.0 Central Administration.

Click Application Management.

On the Application Management page, click Define managed paths under SharePoint Web Application Management.

In the Web Application box, click the Web application that you want to configure.

In the Add a New Path area, type the path in the Path box. Then, click Check URL to verify the URL.

In the Type box, click Explicit inclusion, and then click OK.

Create a new site collection at the URL that you specified in the included path. To do this, follow these steps:

On the Application Management page, click Create site collection under SharePoint Site Management.

In the Web Application box, click the Web application that you want to configure. On the Create Site Collection page, specify a title and a description for the site collection in the Title and Description area.

In the Web Site Address area, specify the URL of the included path that you added in step 1.

In the Primary Site Collection Administrator area and in the Secondary Site Collection Administrator area, specify the administrator for the site collection.

In the Quote Template area, specify the template that you want to use.

In the Template Selection area, click My Site Host in the Select a template box, and then click OK.

Move the personal site provider. To do this, follow these steps:

Under Shared Services Administration, click Shared Service Provider (SSP).

On the home page, click My Site settings under User Profiles and My Sites.

On the My Site settings page, type the URL of the included path in the Personal site provider box in the Personal Site Services area.

Configure the options that you want for the other settings, and then click OK.

Hope it helps.

share|improve this answer
    
Hey thanks. I have to ask my network admin who has setted up this to look into configuration. will back to u. –  Dhaval Kariya Feb 18 '13 at 5:32
    
@DhavalKariya I pretty sure your network admin will and should solve this issue for you anyway :) –  Muhammad Raja Feb 18 '13 at 8:14

The issue can be caused by a few things. 404 however points to a non existing page.

To trace the issue:

  1. Make sure the Web site for MySites in IIS is started.
  2. Make sure the App pool is running
  3. Make sure the server is working (can ping it etc.. and World wide web Service is running)
  4. Use ULSVIEWER to check your Sharepoint ULS logs for the issue.
  5. Chcek if the Sharpeoint User Profile Service is running.
  6. Check that the Username used in FBA has a profile in the User Profile store and that the Mysite Location is pointing to the right URL.

I'll think of more things to check and edit my answer later.

share|improve this answer
    
Hey thanks. I have to ask my network admin who has setted up this to look into configuration. will back to u. –  Dhaval Kariya Feb 18 '13 at 5:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.