Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have just set up a SharePoint server. I need to change the URL for the site to the FQDN from the hostname. When I do this, the site immediately begins prompting me for credentials. Nothing works. Not even the Farm admin account. I have added the new URL to IE as a trusted site. I have reset IIS. Again, nothing has helped.

When I change back to the original URL, everything works fine. Obviously something is hung up on the old URL, but what? Where??

I have spent two days on this and counting. I am VERY frustrated. This is an ASININE problem. Any help would be appreciated.

share|improve this question
    
Did you try adding an entry to hosts file? –  Battlesmith Feb 12 '13 at 4:40

2 Answers 2

You haven't exactly said how you're going about doing this, there should be 3 steps to it: - Change the Alternate Access Mappings for the web application site - Change the IIS bindings to reflect this new fqdn url - Ensure DNS is updated / pointing at the server.

Link to Alternate Access Mapping configuration for 2013 is fairly comprehensive

share|improve this answer

My guess is that you're trying to access SharePoint from a browser on the server itself. In that case what you experience is the result of the Loopback Check which MS has put into IIS.

You can disable this by following KB896861.

By the way my recommendation would be to delete the WebApplication which was set up with just server name and then create it with FQDN (or without hostname in case you want to run apps from that WebApplication) such that SharePoint knows what is your primary name for it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.