Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am very much a noob at sharepoint, so this is probably an easy one. I am trying to get SharePoint 2013 up and running. When I go through the config wizard, it creates a site for me with a URL that starts with http://servername. This is NOT what I want. I want the URL to being http://FQDN since that is how people will actually be accessing it, and I want it on port 80. SharePoint is fighting me tooth and nail on this.

I have no data to preserve. This is a vm with a snapshot pre SP install, so I can easily blow away everything I have and start again. And I have. A couple of times. What I am looking for the easiest way to get what I want.

I would welcome any and all input.

share|improve this question

1 Answer 1

Go into Central Administration and look for Alternate Access Mappings, probably under Server Settings. From there, select your web application in the selector. Edit the public URLs and enter your desired URL as the default zone.

Note: if you have tried to change the URL directly in IIS, then you may have to make the change there as well.

I haven't done this in SP2013 but it should be the same as past versions, though the AAM link might be in a different location.

share|improve this answer
    
I believe that's what I did the first time, but after the change, the site started prompting me for a username and password which failed no matter what I used. Regardless, I will try this again as I have nothing to lose. I will let you know how it pans out. –  Jason Feb 11 '13 at 16:54
1  
That is more likely due to IE settings. Make sure the domain you are trying to access is listed in IE as in the Intranet zone –  Dave Wise Feb 11 '13 at 16:57
    
Ok, I reinstalled and reconfigured. Once again, after I changed the access mapping, IE started prompting me for credentials. I have added the site to the Trusted Sites zone. WTF? I have now spent several days on this one issue. –  Jason Feb 11 '13 at 19:39
    
Add it to the Intranet Zone, not the Trusted sites. Not sure why but Trusted Sites doesn't pass credentials –  Dave Wise Feb 11 '13 at 20:35
    
Also- are you attempting to access the site from the server itself? If so, there is what is known as a "loop back" issue that causes this exact behavior. Method 2 on here seems to work well: support.microsoft.com/kb/896861 –  Dave Wise Feb 11 '13 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.