Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On Windows Server 2012/SharePoint Server 2013 I activated CMIS like this, but when trying to connect to CMIS at http://myserver/cmis/rest/ I get a 404 error:

$ curl -v -u Administrator:mypassword "http://192.168.0.20/cmis/rest/"
> GET /cmis/rest/ HTTP/1.1
> Authorization: Basic QWRtaW5pc3RyYXRvcjpmdWppSTEz
> User-Agent: curl/7.27.0
> Host: 192.168.0.20
> Accept: */*
> 
< HTTP/1.1 404 NOT FOUND
< Cache-Control: private,max-age=0
< Content-Length: 13
< Expires: Wed, 30 Jan 2013 06:27:54 GMT
< Server: Microsoft-IIS/8.0
< X-SharePointHealthScore: 0
< Public-Extension: http://schemas.microsoft.com/repl-2
< SPRequestGuid: 0299fe9b-5958-9008-0000-06e305c41df6
< request-id: 0299fe9b-5958-9008-0000-06e305c41df6
< X-FRAME-OPTIONS: SAMEORIGIN
< SPRequestDuration: 36
< SPIisLatency: 0
< X-Powered-By: ASP.NET
< MicrosoftSharePointTeamServices: 15.0.0.4420
< X-Content-Type-Options: nosniff
< X-MS-InvokeApp: 1; RequireReadOnly
< Date: Thu, 14 Feb 2013 06:27:54 GMT
< 
404 NOT FOUND

Is it a sign that my SharePoint is not ready to be used as a CMIS server?
It is a collaboration site. I just have a test file uploaded to it. Do I need to create workspaces or anything for CMIS to start working?
I am running CMIS Workbench directly on the server, so I guess it is not a network problem.

Via CMIS Workbench I get:

ient.bindings.spi.atompub.CmisAtomPubSpi: Initializing AtomPub SPI...
ncmis.client.bindings.spi.http.HttpUtils: GET http://myserver/cmis/rest/
ncmis.client.bindings.spi.http.HttpUtils: GET http://myserver/cmis/rest/ > Headers: {null=[HTTP/1.1 404 NOT FOUND], X-SharePointHealthScore=[0], MicrosoftSharePointTeamServices=[15.0.0.4420], Content-Length=[13], Expires=[Thu, 24 Jan 2013 09:37:03 GMT], request-id=[72b5fc9b-e969-9008-0000-0a77440e3439], Server=[Microsoft-IIS/8.0], X-Powered-By=[ASP.NET], Cache-Control=[private,max-age=0], X-Content-Type-Options=[nosniff], SPRequestGuid=[72b5fc9b-e969-9008-0000-0a77440e3439], SPIisLatency=[1], Date=[Fri, 08 Feb 2013 09:37:03 GMT], Public-Extension=[http://schemas.microsoft.com/repl-2], X-FRAME-OPTIONS=[SAMEORIGIN], X-MS-InvokeApp=[1; RequireReadOnly], SPRequestDuration=[30]}
hemistry.opencmis.workbench.ClientHelper: CmisObjectNotFoundException: NOT FOUND
share|improve this question

1 Answer 1

up vote 1 down vote accepted

I was using the wrong URL, it seems.

It works with http://myserver/_vti_bin/cmis/rest?getRepositories

Or for a particular site site1: http://myserver/site1/_vti_bin/cmis/rest?getRepositories

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.