Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When doing anything that requires SharePoint to recycle, like deploying a project to SharePoint from Visual Studio, it takes forever for SharePoint to spin up again.

The deployment is about the same speed as with SharePoint 2010, but the wait time till the site is ready to use again is agonizingly slow, ~30-60 seconds sometimes.

While SharePoint is "Working On It" I can see in the Resource Monitor that there is almost no CPU activity (~10%) and there is still memory free, so what is holding up SharePoint, and what can I do to make it go faster?

enter image description here

Software:

  • Windows Server 2012 (running DC)
  • SQL Server 2012 dev edition
  • SharePoint Server 2012
  • Visual Studio 2012
  • My computer is connected to the Internet

Hareware:

  • I5-2520M 2.5 GHz
  • 8 GB RAM
  • 2 x Intel SSD 330
share|improve this question

2 Answers 2

Maybe it is only the dialog that hangs? Did you try opening another window to check whether deployment has finished? :)

share|improve this answer
    
It does not look like it is just the dialog. Closing and reopening the browser window does not affect it. It continues to display the spinner and the text "working on it". –  Egil Hansen Feb 8 '13 at 10:04

Does your machine have Internet access?

I have seen really slow app pool recycles / iisresets due to timeouts whilst waiting to resolve the Microsoft Certificate Revoked List Servers http://crl.microsoft.com. There are various checks when these processes start for the digital signatures to make sure that the assemblies are valid and the signatures havent been revoked.

See the following blog post:- http://joelblogs.co.uk/2011/09/20/certificate-revocation-list-check-and-sharepoint-2010-without-an-internet-connection/

share|improve this answer
    
Hi Simon. My computer does have internet access, and I have tried the various tricks to handle timeouts in regards to crl.microsoft.com. It has not solved the problem, and running stsadm -help is almost instant, so I do not think that is my problem. –  Egil Hansen Feb 8 '13 at 10:34
    
What are the disks doing? If you start up Performance Monitor and check the Logical Disk Drives Average Disk Queue Length. If the values are over 2 then the O/S is waiting for the disk subsystem. I would suggest splitting the DC / SQL onto separate VMs too. I have a DC with 1GB, SQL with 4GB and SharePoint has 8GB but then I have 16GB of RAM available. –  Simon Doy Feb 8 '13 at 11:11
    
Disk Queue Length never passes 0.02, so I don't think it is a disk performance issue. –  Egil Hansen Feb 8 '13 at 11:35
    
Definately doesnt seem to be that. What content is the page loading? Is there any content that would use Service Applications, such as Search or BCS? Have a look in the ULS log using ULSViewer tool to see if there is activity there. –  Simon Doy Feb 8 '13 at 11:49
1  
So it looks like you deploy your solution each time, is that right? If thats the case then that will take some time but you can be more efficient. Though it will depend on the type of change you are making. Download the CKS:Dev extension for Visual Studio. For example If you are just changing code then this will help by giving you an option to deploy your binaries as part of the process and then recycle the app pool after the binaries have been copied that will definately speed up your build/debug cycle. –  Simon Doy Feb 8 '13 at 12:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.