Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Not sure yet if something wrong on my Foundation installation or a new SP2013 bug. On SP2013 (didn't happen on SP2010!) - create new Document Library app and use Advanced Settings to set it to Manage Content Types. Then add a new Content Type (I used Link to Doc but Image etc - all seems to be same). Note it is not yet "Visible on new button" (which should be the default once added) so click "change new button order and default content type" to set it - no matter what you do here, it's ignored!!

So basically you can't add any further CT, just have the standard Document CT. Further, it shows the additional CTs (without the Visible ticked) but of course they aren't on the New button!

Am I the only one with this serious problem?

NB: Just remembered I did successfully add links in one Doc Library on this SP2013 farm, but deleted it a while ago and now all new Libs have this behaviour. The only major thing I have done since then is install Office Web Apps on another server and connect it to the farm, which naturally should not have this impact, so may be not the culprit. Anyone with this showstopper please say!

share|improve this question
    
We are experiencing the same issue, after an upgrade to 2013 from 2010. We did not update anything using Design Manager etc, but the list of content types in the library on the Library Setting -> Content Types does not show checkmarks on the items which are selected to show on new button, even though they work fine when you create a new one. –  ElliJ May 21 at 21:45
add comment

1 Answer 1

up vote 0 down vote accepted

Ok, to clear this, I managed the CTs for the Doc Libraries in Design Manager 2013 instead, where they do correctly show as "yes" for "Show on new menu". Then they appeared ok on the user frontend! However, they are still unticked "Visible on new button" in Library Settings -> Content Types, even though they do show to user - it looks like only the first CT is ticked, all others are unticked on that screen even if they do still show (eventually, after managing in SPDesigner). HTH, it was urgent!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.