SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've an issue with my SP2013 installation. It's a single server installation on system named "internal". I've added an AAM for

  • Default ( (required for an anonymous site collection)
  • Internet ( (ssl url for document management site col)
  • Custom (http://internal)

My search content source is set to http://internal. The search results looking good, every URL is correct but the link "View Library" within the hover panel links to http://internal/.... I've also added a "server name mapping" for http://internal to, but that one is not changing (even after a full crawl).

Any idea, how to change this behavior, so that also the "View Library" link is working on the internet https domain?

Setting the content source to the url throws an exception that it cannot be accessed by the crawler account.

share|improve this question
No one with an idea? – marco Feb 12 '13 at 12:30
I to am having the exact same problem and have tried the same solutions, any ideas yet? -Eric Niemiec – user15657 Mar 18 '13 at 0:46
up vote 0 down vote accepted

Fixed it by myself. I've added to the content source (as the only content source). Then added the site to the "local intranet" zone in Internet Explorer and added the domain "" to the hosts file pointing to And now the "magic trick": Disable the loopback check (if not already done). You can then test it by opening the https url in Internet Explorer on the SharePoint server. If you can successfully login with the content access account, everything is ok.

share|improve this answer

protected by Community Mar 25 '13 at 9:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.