Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have Sharepoint web app with claims based authentication and ADFS as Identity Provider. In my test enfironment ADFS and Sharepoint are on the same machine. I'm using TMG for mapping between external and internal url.So my urls are for example:

Internal url for sharepoint app: https://sharepointtest:555
External url for sharepoint app: https://sharepointtestpublic.com:555
Internal url for adfs: https://sharepointtest/adfs/ls
External url for adfs: https://sharepointtestpublic.com/adfs/ls

In sharepoint app I have alternate access mapping:

Default: https://sharepointtest:555
Internet: https://sharepointtestpublic.com:555

If I configure my sharepoint app to use only NTLM authentication in authentication providers and I'm trying to access sharepoint from public url https://sharepointtestpublic.com:555 the windows logon popup shows and I can login into the sharepoint.

But when I configure sharepoint app to use only Trusted identity provider pointing to the ADFS (NTLM is turned off) and I try to access the public url I'm getting IIS error:

Error Code: 500 Internal Server Error. The request was rejected by the HTTP filter. Contact the server administrator. (12217)

The output from the fiddler is:

GET https://sharepointtestpublic:555/ 302 Found to https://sharepointtestpublic.sk:555/_layouts/Authenticate.aspx?Source=%2F

GET https://sharepointtestpublic:555/_login/default.aspx?ReturnUrl=%2f_layouts%2fAuthenticate.aspx%3fSource%3d%252F&Source=%2F 500 ( The request was rejected by the HTTP filter. Contact the server administrator.  ) (text/html)

In the sharepoint log I see only:

Access Denied: Authentication is required.

I'm trying to find out what can be the problem. Why NTLM works and Trusted Identity provider not. Do I need some special settings on the IIS?

thanks for your advices.

share|improve this question
    
I have solved the problem by changing the settings (clear Verify normalization checkbox) on TMG. –  zosim Feb 4 '13 at 13:12
    
Could you post this also as an accepted answer? –  Thomas Vochten Feb 4 '13 at 13:26

1 Answer 1

up vote -1 down vote accepted

I have solved the problem by changing the settings (clear Verify normalization checkbox) on TMG.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.