Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have an Info Path form which contains a drop down list attached to a Data connection. The data is coming from a SharePoint list with well over 20,000 records. To combat the size of this list we are querying/filtering the list by country, reducing the records count.

I know that the max records returning for any given country is 800 yet i still get an error when trying to display the drop down in the info path form.

Is there any way round it?

TIA.

S

share|improve this question
    
800 is still a very large number for a drop-down. Can't you whittle it down more? Also, how are you filtering the data? In the drop-down properties? That will still pull 20,000 records and try to display only the filtered ones. Another way is to set the query field for country in the data connection to the specific country and then query the data connection. That will return only the records for the country. –  teylyn Jan 30 '13 at 21:42
    
Your were right, the more i thought about it the more i realised this would not be a good user experience. Instead I created a bespoke search page which search on a scope and edited the XSLT to include my own buttons to "Select" a record which then auto populates the info path form...works like a dream now...Very happy with it now. –  Stephen Feb 1 '13 at 9:29
    
Stephen, could you post your answer about your solution? "edited the XSLT to include my own buttons to "Select" a record which then auto populates the info path form" sounds interesting and non-trivial –  Gennady Vanin Novosibirsk Feb 1 '13 at 17:21
    
Yes I am thinking about writing a blog post about how i done it as in the end the solution was perfect but it did take me around 2 days to complete and it was quite involved. lots of JS! When i get round to doing it i will post a link here. –  Stephen Feb 7 '13 at 9:07
    
Stephen, Have u got any chance to post the article. please let us know. we love to go through it. –  user16460 Apr 18 '13 at 18:01
add comment

1 Answer 1

Increase the Data Connection Response Size

Change the Response Size in kilobytes

in Central Administration > General Application Settings > Configure InfoPath Form Services.

Configure Infopath Forms Services

share|improve this answer
    
Thanks for the reply Gennady...I'm using Sharepoint online so this would not work for me...worked out a solution which does the job as detailed above. Thanks for the intput. –  Stephen Feb 1 '13 at 9:33
    
Oooops, I have NOT NOTiced the tag "Sharepoint-online" –  Gennady Vanin Novosibirsk Feb 1 '13 at 17:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.