Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

i have set alert on list item "AssignedTo" (A task is assigned to Me). It was working fine since last 1.5 year. But now suddenly it fires twice. So all of the users assigned Task get alert twice. I dont know why it happens. how to resolve it?

share|improve this question
    
Have you added a workflow to it recently? –  ghangas Feb 4 '13 at 16:35
    
no..i have not added any workflow to it –  Dhaval Kariya Feb 5 '13 at 5:31
add comment

1 Answer

up vote 0 down vote accepted

Finally i found the solution. Users was getting alert twice because my one of colleagues has deployed event receiver that is used to set alert for users. So some of the users have alerts set twice for the same list. I removed unnecessary alerts and asked my colleague to modify his code.

Regards,

Dhaval

share|improve this answer
    
"one of my colleagues has deployed event receiver" -- You guys will be in big trouble if you don't develop and adhere to a strict governance regime about change management and testing new functionality. If one user can deploy a solution that breaks functionality elsewhere, how can you ever expect a stable farm? –  teylyn Mar 29 '13 at 8:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.