Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have two lists, A and B.

I created A and then used Designer to create a custom New and Edit forms and everything works fine.

I recently created list B, created custom new and edit forms but they aren't loaded. If I create a new list item or edit an old one. The form that comes up is the default. In Designer it names my forms as the Supporting Files. If I click New or Edit and manually type the name of my forms as the URL then my forms appear so I don't think there's anything wrong with the forms themselves. The custom forms for both lists ere created the same way, all I've done is remove certain fields, nothing too fancy.

I'm sure I'm missing something obvious but can't think what o_0

share|improve this question
    
I'm not sure of the source of your problem, but make sure that you are going through the correct steps. Ensure that you are first navigating to the target list in Designer and make a copy of the New/Edit forms for backup, then make your edits and ensure that you get a prompt saying you are customizing a page from the site definition. More information here: cjvandyk.com/blog/Articles/… –  Alex Jan 29 '13 at 19:27
    
Yep I've done all of that and yet it still only works for the first list! –  Enilorac Jan 29 '13 at 20:53
    
You should provide more details then about what exactly you tried, e.g. what kind of list, where you created it, any differences that you can think of from the first list you created. Without more information it's hard to determine a solution. I can however suggest to try testing it more: If you create a third list and try customizing those forms, does it work? If you delete the first list, and create it again and re-customize the forms, does it still work? Narrow down and isolate the problem if you can. –  Alex Jan 29 '13 at 21:55
add comment

3 Answers

Under the "Supporting Files" tab, make sure "Content type specific forms:" is set to "Item" not "Folder."

share|improve this answer
add comment

Try this - 1) Make a backup copy of the original new and edit forms. 2) Rename the custom new and edit forms as - NewForm.aspx & EditForm.aspx, respectively. To avoid naming conflicts with the original ones, save them under new names (make sure when SharePoint asks you to update links, you hit No button!) 3) Refresh (Ctrl+f5) the list view page, and then try.

If you are still not able to load your custom forms, then one of the options is to do things the crude way - write JavaScript redirect code to your custom forms. This will involve modifying the "OK" and "Cancel" buttons in the list, and the Back button of the browser as well...this would be another topic :)

share|improve this answer
add comment
up vote 0 down vote accepted

As annoying as it is. I tried again later and it fixed itself so I don't know what happened! It's happened again since and every time it eventually fixes itself

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.