Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a Doc Library using a custom content type with about 15 managed metadata fields in it.

For some reason filtering on one particular column whether it be MM Navigation, MM Key Filters, or just a basic column filter returns 0 results even though there is data that should match. Though fields added long before this one in particular still work.

Removing and remaking the field does not correct the issue. Even further, adding other MM fields to the content type makes them also return 0 results when filtering.

Lastly, I've tried making a new doc library and testing. No MM fields will work there.

I am able to produce this behavior across 3 different farms using the backup of this site collection.

Any ideas?

share|improve this question
1  
Hi, What version of SharePoint are you using? When you say filtering, do you mean Search or just filtering a view or the items in a column? Thanks –  MonkeyWrench Jul 29 '13 at 18:25
1  
@JonJMills - please provide environment specs such server version, database and farm configuration. I am also researching "data loss" in a CQWP on a SharePoint 2010, windows 2008 R2, newsgator configuration. What is happening is that the choice fields data is popping up blank in production although when the same information is replicated in staging the data is stable. –  user18725 Aug 5 '13 at 19:22

1 Answer 1

It sounds like your document tags are the same as your navigation and filter tags, but perhaps the backing MM ids are off. This can happen in a scenario like the following:

  1. Create MM taxonomy A with tags 'red', 'green', 'blue'
  2. tag your documents with 'red', 'green', 'blue'
  3. Delete MM taxonomy A (likely by accident)
  4. Recreate new MM taxonomy A with tags 'red', 'green', 'blue'

It is my understanding that MM tags have a backing ID, so the tags created in step 1 have a different ID than the ones created in step 4.

TRY THIS:

Just use MM Navigation and only have the offending field - remove all of the other columns - try and re-tag one or two documents and use a value that is presented as a valid option in the MM Navigation pull down.

Then navigate to that value in the MM navigation and see if the one or two documents appear.

Hope this helps (and works).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.