Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I tried to create a Web Application using Central Admin. It created web app without displaying any error, I can browse site too after creating site collection and that, but content db got no permissions at all.

I am using SPAdmin account for creating Web App and also added it as SysAdmin in SQL server. If I create Content DB using Power Shell it gets right permissions I guess e.g. SPFarm.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

In order to create a web application via GUI (CA) with windows authentication you have to be:

  • a member of the Farm Administrators SharePoint group
  • a member of the local Administrator group on the computer running Central Administration.

With PowerShell, you need to add permission using Add-SPShellAdmin command, and also make sure to be a member of the local Administrators group on the computer running Windows PowerShell.

I would recommend you to identify the main service accounts such as Application Pool account, Farm admin account, SP/SQL Server Installation account etc to identify the root cause of problem.

Happy SharePointing!

share|improve this answer
    
User is memeber of Farm Admin, local admin and sys admin in SQL server, most app pools are using SPFarm but couple are using SPService accounts, but my web app which I created is using SPFarm account –  Muhammad Raja Jan 25 '13 at 8:07
    
I stopped looking into it for the moment as I passed 70 - 667 exam but I might come back to it later on. –  Muhammad Raja Feb 1 '13 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.