Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Background

I have a content type (CT2) with 7 site columns. CT2 inherits from CT1 which has 3 columns.

We are using CT2 in several document libraries.

In one document library

  • The columns for CT2 work as expected
  • The columns for CT1 display when selecting columns for a view
  • The columns for CT1 display in a standard view
  • The columns for CT1 DO NOT display in a datasheet view
  • The columns for CT1 DO NOT show up in list settings
  • When I attempt to add the site column it does not show up as an option

For the most part it did not seem to make a difference at first but this uncertainty does give me general worry but not being able to do easy edits in datasheet view is an issue now.

Question

Is there any reason why a site column from a content type is in a document library would not show up in the document library settings page on in the datasheet view?

share|improve this question
    
How did you create the content type, UI or via Code? –  sssreddy Jan 23 '13 at 1:34
    
Have you checked the value of ShowInListSettings for that field? –  Naim Apr 2 at 12:19
add comment

1 Answer

Knowing that "Item" is the parent content type to documents, try to open the item content type in datasheet view, and do you see the columns displayed there?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.