Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Here is what I have done.

I have created one new blank InfoPath Form and added (for example) 3 fields, say A1, B1, C1.

A1 = Decimal Field = Decimal Preceding : Auto

B1 = Decimal Field = Decimal Preceding : Auto

C1 = Decimal Field (Calculation C1 = A1 * B1) = Decimal Preceding : 2

Now, when I preview InfoPath forms and enter values like

A1 = 5.29

B1 = 4.23

I gets C1 = 22.38

Works fine.

I deployed it to the SharePoint Library, configured Submit Options to save data to the same library.

Now, in my library, I said Add New Item (Add Document) which opens up the InfoPath form and I entered values as below:

A1 = 5.29

B1 = 4.23

I gets C1 = 22.38

Works fine.

BUT..now when I click on submit data, in my library, in C1 column, I get 22.3767

That's the problem (why not 2 decimal only, why 4?)

This was just an example, as per my calculation, the real value is 15.67 but in my library, I'm getting it as 15.6666666666

Any solution?

share|improve this question
add comment

2 Answers 2

Now, when I preview InfoPath forms and enter values like

A1 = 5.29

B1 = 4.23

I gets C1 = 22.38

Works fine.

Infopath preview is alwasy in local/client Filler, the data is formatted according to local regional settings of computer (Windows) where it is viewed.

BUT..now when I click on submit data, in my library, in C1 column, I get 22.3767

The Infopath browser forms can be opened from Sharepoint both in browser and in Filler. When it is opened in browser, it is showing data according to server's settings.

See more in my answer to:

Update:
Currently I do not have access to any server but I do not think that it is conceptually different from possibilities of configuring it at a workstation.

Here is a screenshot from my Windows XP SP3 Control Panel (enter control in command line) > Regional and Language Settings > Regional Options tab > press Customize... button on the right of Select an item to match its preferences, or click Customize to choose your own format: combobox > Numbers tab > No. of digits after decimal dropdown list of choices

You can even define Euro currency for United States :)

Configuring formatting options in control panel

share|improve this answer
    
Ok, I got it, but your answers described for problem of date picker, what I am looking is for decimal preciseness, any solution for it now? –  NICK Jan 23 '13 at 5:24
    
See update in my answer –  Gennady Vanin Novosibirsk Jan 23 '13 at 13:40
add comment

I got the answer!!

You need to publish your form again and check the check box for editing the column data so you can edit that column in library!!

Once it's editable, just change the decimal points to Auto, 1, 2, 3, etc.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.