Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm getting error "List does not exist" error when I try to enable Site Collection Audit settings. When I click on the Browse button under "Audit Log trimming" it throws an error "List does not exist". Usually the pop up form will display the SharePoint lists and content structure.

I found this solution in Technet forums. Will this help? Have anyone faced similar issue and fixed it.

Possible solution:-

deactivate the Publishing feature at site collection and site level. 1st deactivate at site level and then deactiviate at Site collection level 2nd activate at site collection level and then activate site level. Publishing Feature at site level: SharePoint Server Publishing & SharePoint Server Standard Site features Publishing Feature at site Collection level: & SharePoint Server Standard Site Collection features this will reacreate the corrupted list.

Actual forum post. http://social.technet.microsoft.com/forums/en/sharepointadminprevious/thread/078ae118-fe80-47b6-ac33-7af34cf55583

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Deactivate and activate SharePoint Server Publishing at site collection and site level fixed this issue as mentioned in the link

http://social.technet.microsoft.com/forums/en/sharepointadminprevious/thread/078ae118-fe80-47b6-ac33-7af34cf55583

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.