SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I hide the list using

list.Hidden = true;

It's hidden from the Quick Launch and it's also hidden from the Sharepoint Designer.

I'm rather interested in a useful feature for lists in Sharepoint Designer called "Hide from browser". Can this option be set from code?

share|improve this question

I have seen other posts where users claim that SPList.Hidden is somehow different from SharePoint Designer's option Hide from browser.

It is my belief that both the code approach and the designer setting are one and the same.

A hidden list does not appear on the Documents and Lists page, Quick Launch bar, the Modify Site Content page, or the Add Column page as an option for lookup fields.

A potential reason why a list no longer appears in SharePoint Designer after you mark it as hidden is usually when the permission level for your user account do not allow you to see hidden lists. This happens for example, when you are site owner (full control), but not site collection administrator.

share|improve this answer
    
I am a site collection admin, and a list I 'hid from browser' earlier today in SPD2013 is now nowhere to be found in SPD! – hudsonsedge Dec 4 '15 at 1:15
    
I stand by. If you run list.Hidden = $true followed $list.Update(), the "Hide list from browser" is immediately checked. Not sure what are the exact permission levels required to see lists even when hidden. – Tiago Duarte Dec 4 '15 at 11:13
    
Egads. Found them finally. – hudsonsedge Dec 4 '15 at 21:11

Actually via SharePoint Designer you do have an option to "show" again the list. The operation you mentioned, performed via code, does exactly that!

How to open hidden list and un-hide it in Designer:

1) Open SharePoint designer 2010.

2) Click the “All Files” folder at the bottom in left pane.

3) Right click your hidden list from “All Files -> Lists” folder and choose property.

4) Now you have your hidden list open in SPD.

5) In List settings-> General Settings: Un-check the “Hide from browser” and save.

share|improve this answer
    
What I want to achieve is the opposite: is there a code equivalent to Designer's "Hide from browser" that works exactly like the Designer option? – Maurice Kay Jan 21 '13 at 10:12
    
You mean that setting "Hidden" to False (followed by a call to Update), doesn't show up again?? – Marius Constantinescu - MVP Jan 21 '13 at 10:13
    
Do people even read the question? – David Jun 8 '15 at 15:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.