Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I inherited a site with a sequential workflow (created in Visual Studio 2008). The workflow is attached to a content type and is set to run only on item created. Recently, I attached three declarative workflows (SharePoint Designer) to the same list the content types are attached to. Ever since, the sequential workflow will randomly run twice and create duplicate approval tasks. Once I took the declarative workflows off the list, the duplication problem seemed to go away.

SharePoint Designer Workflows: Two of the SPD workflows I added do not alter data in the list, they only check an expiration date, pause for a duration (30 and 60 days), then send an email. The last work flow does update the list, but only after it pauses for 90 days. I am not sure why the SPD workflows would trigger two instances of the VS workflow to run, especially when the VS workflow is set to run on item created. Also, the timing between the two instances of the VS workflow is like 15 minutes apart. The VS workflow is not being started manually either.

Any help is appreciated

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Have you tried adding a pause to the Visual Studio workflow of 1 minute at the begining?

I have several SP Designer 2007 workflows that would send duplicate emails but if the workflow started with a 1 minute pause then it wouldn't. Not sure why it helps but it solved my problem!

share|improve this answer
    
I did not. The SPD workflows, however, are staggered with five minute pause between each. I'll have too look at pausing the VS workflow. Thanks. –  steveareeno Feb 13 '13 at 14:19
    
I misunderstood your answer. I had pauses in the SPD WFs. However, the VS WF had no pause. I found this which basically corroborates what you are saying. –  steveareeno Feb 28 '13 at 21:06
    
I want to confirm that adding a pause to the visual studio workflow fixed the problem. –  steveareeno Mar 19 '13 at 13:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.