Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Foremost, I am not an administrator of SharePoint site and have very limited controls on my page. Earlier, I had created a list (custom list with Datasheet view). I had created over 20 views (one for each country) on this list. The list had exceeded 5000 records. So, I had indexed the list against the country code (based on which the views were filtered). It was working fine, even for those countries / views that had over 3000 records.

Recently, I had to delete and re-load the records for some reason. The number of records did not change much, but now, the views with over 1000 records are throwing list view threshold exceeded error.

For delete and load, I did the following: - I have deleted records through front-end and cleared them from Recycle Bin. Then, I copied contents from excel sheet and pasted into datasheet view. - On seeing error, I cleared off contents from list again and tried to push records from MS Access linked table using an Access SQL query. Error comes back promptly after this type of loading too.

Am I missing something here? How was it working earlier? Why is it not working now? Please help.

Regds, SKB

EDIT: I found something interesting today. Actually, there are three tables, and their behaviors are quite different - and definitely, not consistent. Please refer to the attached image that does the comparison List View Behavior and Records count comparison

I am, I am missing out something here. I am banking on your expert opinions

Regds, SKB

share|improve this question
    
Hmm... I have either asked an uninteresting question or a too difficult one... –  SKBPillai Jan 20 '13 at 11:16

1 Answer 1

I don't have an answer as to why you are getting errors, but I do have a solution:

  1. Create a blank list template of each list (ensure the include content checkbox is NOT checked), the template will include your views but not your data.

  2. Create a new list from that template.

  3. Open the new list and the old list in datasheet view and copy and paste all records.

If it works, delete the old list. Repeat for the other two lists.

More detailed answer: If you really want to keep your list names, you have to do this twice.

  1. Create template of List1 (you only have to do this once).
  2. Create list from List1 template, name it List1A.
  3. Copy from List1 to List1A.
  4. Delete List1.
  5. Create list from List1 template, name it List1.
  6. Copy from List1A to List1.
  7. Delete List1A.
  8. Repeat for List2 and List3.
share|improve this answer
    
Hi Craig, Thanks for suggestion. But I am afraid that is going to have problems for me. I have distributed excel sheets to country users that connects to these tables using connection string and macros. Further, I use KwizCom for view level permissions. Every time I create a new list, I would have to redo that as well. Hence, that would be very difficult, especially doing it once a fortnight! –  SKBPillai Jan 22 '13 at 9:35
    
OK, I thought this might help narrow down where you were having a problem. I don't quite understand why you think you would have to do it more than once. –  CigarDoug Jan 22 '13 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.