SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't make "Site Feed" activated from Managed Site Features. It says

An unexpected error has occurred.

I get logs with

get-splogevent -starttime (get-date).addminutes(-1) | fl message > c:\errors.txt

Here is the error:

viewstatelog: Failed to write to the velocity cache


I think I found the solution for this error. I write these commands at Powershell:

$instanceName ="SPDistributedCacheService Name=AppFabricCachingService"
$serviceInstance = Get-SPServiceInstance | ? {($_.service.tostring()) -eq $instanceName -and ($ -eq $env:computername}

But It says there is no available memory for Provision().

How can I clear cache?

share|improve this question
What version of SharePoint are you using? – Thomas Vochten Jan 16 '13 at 16:00
Sharepoint 2013 – e.ozmen Jan 17 '13 at 6:12

Check out this post which will help you in fixing the error which I have faced before configuring the News Feeds in SharePoint 2013.

Site Feeds Error in SharePoint 2013

share|improve this answer
Hi @Maruthu and welcome to our site. When you post answers please remember to mention when you promote your own blog. The community tends to vote down overt self-promotion and flag it as spam. Post good, relevant answers, and if some (but not all) happen to be about your product or website, that’s okay. However, you must disclose your affiliation in your answers. Read about expected behaviour. Also remember that "link only answers" is of less use for our site, since links tend to die. Add a good summary of your answer and then link. – Anders Rask Aug 20 '13 at 8:28

You can use the PowerShell cmdlet Clear-SPDistributedCacheItem to clear your cache.

Clear-SPDistributedCacheItem -ContainerType DistributedLogonTokenCache
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.