SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

By default SharePoint has paging 1-30 items in a document library. I want to change this to 1-50 or even 1-100.

How can I do this? I've been looking on the internet but I cannot find a fitting solution.

I would like to change something so all users have this change by default instead of changing view each time.

Thanks

share|improve this question
up vote 4 down vote accepted

If you have list definition, you can change it in Schema.xml.

Go to Views, find your default view and set RowLimit to 50/100

share|improve this answer
1  
Sorry for late reply, but thanks! I've changed it to FALSE instead. <RowLimit Paged="FALSE">30</RowLimit> – Rob Jan 31 '13 at 14:55

You would need to modify item limit of your current view (like allitems). Go to list/library settings, click on your current view. Under the section "Item Limit", enter your desired paging size (like 100), and select the radio button "Display items in batches of the specified size".

share|improve this answer

There is an easier way to do this. Simply go to the List in Sharepoint, click on Modify View, and then scroll down to "Item Limit" and then change the setting from 30 to whatever you want.

share|improve this answer
    
This didn't exist back in 2013. Thanks for the update – Rob Jul 21 '15 at 18:03
1  
No, its exist in 2013 also – Rajesh Joshi Dec 11 '15 at 4:35

SO what you have to do is download the SharePoint Manager 2010, drill down to the site and the default view for the list in the left nav. On the right under the properties tab you will see an alphabetical list of properties. The one you want is called called Query if you look in the value field for Query you will see the string - GroupBy Collapse="TRUE" GroupLimit="100">

That 100 used to be 30. That's why after I grouped my list no matter what it only showed 30 items worth. Changed that to 100 and now the full page is populated with the list items.

share|improve this answer

Just to add to Zeeple:

Edit your page > click on the web part > click modify (and again modify view) > scroll down and click on item limit > change to whatever number you want and leave on the "display items in batches of the specified size".

It worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.