SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason the Quick Launch Items has gone missing from my custom masterpage and I am not sure hwo to get them back...

The code for my Quick Launch:

                    <SharePoint:DelegateControl runat="server" ControlId="QuickLaunchDataSource">
        <asp:SiteMapDataSource SiteMapProvider="SPNavigationProvider" ShowStartingNode="False" id="QuickLaunchSiteMap" StartingNodeUrl="sid:1025" runat="server" />
                    <SharePoint:UIVersionedContent UIVersion="4" runat="server">
                            <SharePoint:AspMenu id="QuickLaunchMenu" runat="server" DataSourceId="QuickLaunchSiteMap" Orientation="Vertical" StaticDisplayLevels="2" ItemWrap="true" MaximumDynamicDisplayLevels="2" StaticSubMenuIndent="1" SkipLinkText="" CssClass="s4-die">
                                    <asp:menuitemstyle CssClass="ms-navheader" />
                                    <asp:menuitemstyle CssClass="ms-navitem" />
                                    <asp:submenustyle CssClass="ms-navSubMenu1" />
                                    <asp:submenustyle CssClass="ms-navSubMenu2" />
                                    <asp:menuitemstyle CssClass="ms-selectednavheader" />
                                    <asp:menuitemstyle CssClass="ms-selectednav" />
                    <SharePoint:UIVersionedContent UIVersion="4" runat="server">
                            <SharePoint:AspMenu id="V4QuickLaunchMenu" runat="server" EnableViewState="false" UseSimpleRendering="true" UseSeparateCss="false" Orientation="Vertical" StaticDisplayLevels="2" MaximumDynamicDisplayLevels="0" SkipLinkText="" CssClass="s4-ql" />
                            <asp:SiteMapDataSource runat="server" ID="SiteMapDataSource1" SiteMapProvider="SPNavigationProvider" />

There is simply no items on the list. And I can't get them back.

share|improve this question
up vote 3 down vote accepted

Go to Site Settings . Under Web Designer Galleries click master pages and page layouts. Look for your master pages version history. Then reload to the which version you want.

share|improve this answer
Thank you! This worked like a treat! – Morten Hagh Jan 14 '13 at 13:40

Check in the Site Settings for any settings related to Navigation before changing anything else. Code presented seems proper. Do you see the "Recycle Bin" and "View All Site Content"? (if yes, it can be most likely due to settings rather than the master page)

  • If you use Publishing Site - check Navigation and make sure that under Current Navigation you have anything either Checked (Pages/Subsites) or add manually links.
  • If you use Collaboration Site, make sure that Quick Launch hasn't been disabled (un-checked) in The "Tree View".
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.